Go Down

Topic: No such file or directory error re: core cache when compiling (Read 195 times) previous topic - next topic

Michael_EB

Hello,
My name is Michael. I am 70 years old and retired
I am a beginner with Arduino and have problems with
uploading to board "ATmega 328 / P / PB".
If I do the sketch "TEST" the following error appears:

Arduino: 1.8.5 (Windows 10), Board: "ATmega328/P/PB, Atmega328P, Yes (Normal Arduino Serial/USB Upload), 8MHz Internal Oscillator, LTO Enabled, Disabled, Default, Default, Default"

C:\Users\Michael_Erich\Desktop\Arduino\arduino-1.8.5-windows\arduino-1.8.5\arduino-builder -dump-prefs -logger=machine -hardware C:\Users\Michael_Erich\Desktop\Arduino\arduino-1.8.5-windows\arduino-1.8.5\hardware -hardware C:\Users\Michael_Erich\AppData\Local\Arduino15\packages -tools C:\Users\Michael_Erich\Desktop\Arduino\arduino-1.8.5-windows\arduino-1.8.5\tools-builder -tools C:\Users\Michael_Erich\Desktop\Arduino\arduino-1.8.5-windows\arduino-1.8.5\hardware\tools\avr -tools C:\Users\Michael_Erich\AppData\Local\Arduino15\packages -built-in-libraries C:\Users\Michael_Erich\Desktop\Arduino\arduino-1.8.5-windows\arduino-1.8.5\libraries -libraries C:\Users\Michael_Erich\Desktop\Arduino Sketchbook\libraries -fqbn=diy_atmega8_series:avr:atmega328_diy:version=atmega328p,boot=optiboot,clock=8MHz,lto=enable,bodlevel=disabled,advclk=auto,advfrq=auto,advups=auto -ide-version=10805 -build-path

C:\Users\Michael_Erich\Desktop\Arduino Sketchbook\libraries\EnableInterrupt/EnableInterrupt.h:22:125: note: #pragma message: NOTICE: *** EnableInterrupt library version pre-0.9.6. This is not a problem. Keep calm, and carry on. ***

#pragma message("NOTICE: *** EnableInterrupt library version pre-0.9.6. This is not a problem. Keep calm, and carry on. ***")

                                                                                                                          ^
"C:\Users\MICHAE~1\AppData\Local\Temp\arduino_build_636007\libraries\LowPower-master\LowPower.cpp.o" "C:\Users\MICHAE~1\AppData\Local\Temp\arduino_build_636007/..\arduino_cache_906710\core\core_diy_atmega8_series_avr_atmega328_diy_version_atmega328p,boot_optiboot,clock_8MHz,lto_enable,bodlevel_disabled,advclk_auto,advfrq_auto,advups_auto_71aab21841e7fe017bd104d7aeaab0c2.a" "-LC:\Users\MICHAE~1\AppData\Local\Temp\arduino_build_636007" -lm
avr-gcc: error: C:\Users\MICHAE~1\AppData\Local\Temp\arduino_build_636007/..\arduino_cache_906710\core\core_diy_atmega8_series_avr_atmega328_diy_version_atmega328p,boot_optiboot,clock_8MHz,lto_enable,bodlevel_disabled,advclk_auto,advfrq_auto,advups_auto_71aab21841e7fe017bd104d7aeaab0c2.a: No such file or directory

Bibliothek EnableInterrupt in Version 0.9.8 im Ordner: C:\Users\Michael_Erich\Desktop\Arduino Sketchbook\libraries\EnableInterrupt  wird verwendet
Bibliothek AskSinPP-master in Version 4.1.0 im Ordner: C:\Users\Michael_Erich\Desktop\Arduino Sketchbook\libraries\AskSinPP-master  wird verwendet
Bibliothek LowPower-master in Version 1.6 im Ordner: C:\Users\Michael_Erich\Desktop\Arduino Sketchbook\libraries\LowPower-master  wird verwendet
exit status 1
Fehler beim Kompilieren für das Board ATmega328/P/PB.

Who can tell me what the problem is.
Yours sincerely
Michael





pert

Try closing all Arduino IDE windows, restart the Arduino IDE, and then attempt to upload again.
That will clear the compilation cache and hopefully fix the error.

Michael_EB

Hello,
Thank you for your quick message.
As recommended, I carried it out.
It came the hint:
In file included from C: \ Users \ Michael_Erich \ Desktop \ Arduino Sketchbook \ sketch_sep09b \ sketch_sep09b.ino: 11: 0:

C: \ Users \ Michael_Erich \ Desktop \ Arduino Sketchbook \ libraries \ EnableInterrupt / EnableInterrupt.h: 22: 125: note: # pragma message: NOTICE: *** EnableInterrupt library version pre-0.9.6. This is not a problem. Keep calm and carry on. ***

  #pragma message ("NOTICE: *** EnableInterrupt library version pre-0.9.6." This is not a problem. Keep calm, and carry on. *** ")

At the end is:
The sketch uses 20776 bytes (64%) of the program memory space. The maximum is 32256 bytes.
Global variables use 756 bytes of dynamic memory.

That should be OK now?
Yours sincerely
Michael

pert

Yes. Everything is working fine now. The sketch compiled successfully. Enjoy!
Per

Michael_EB

Hello,
Unfortunately, the joy is not very big.
I have now tried to upload the sketch.
The following error message came up:

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C: \ Users \ Michael_Erich \ AppData \ Local \ Arduino15 \ packages \ arduino \ tools \ avrdude \ 6.3.0-arduino14 / etc / avrdude.conf"

         Using Port: COM1
         Using Programmer: arduino
         Overriding Baud Rate: 38400
         AVR Part: ATmega328P
         Chip Erase delay: 9000 us
         PAGEL: PD7
         BS2: PC2
         RESET disposition: dedicated
         RETRY pulse: SCK
         serial program mode: yes
         parallel program mode: yes
         Timeout: 200
         StabDelay: 100
         CmdexDelay: 25
         SyncLoops: 32
         ByteDelay: 0
         PollIndex: 3
         PollValue: 0x53
         Memory detail:

                                  Block Poll Page Polled
           Memory Type Mode Delay Size Indx Paged Size Size # Pages MinW MaxW ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ----- - ----- ----- ---------
           eeprom 65 20 4 0 no 1024 4 0 3600 3600 0xff 0xff
           flash 65 6 128 0 yes 32768 128 256 4500 4500 0xff 0xff
           lfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
           hfuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
           efuse 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
           lock 0 0 0 0 no 1 0 0 4500 4500 0x00 0x00
           calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
           signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

         Programmer Type: Arduino
         Description: Arduino
         Hardware Version: 3
         Firmware Version: 6.2
         Vtarget: 0.3V
         Varef: 0.3V
         Oscillator: 28,800 kHz
         SCK period: 3.3 us

aIf you upload the sketch, an error has occurred
vrdude: stk500_initialize (): (a) protocol error, expect = 0x14, resp = 0xa8
avrdude: initialization failed, rc = -1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500_disable (): protocol error, expect = 0x14, resp = 0xaa

avrdude done. Thank you.

How can I solve the problem?
Yours sincerely
Michael

Go Up