Go Down

Topic: BNO-055 Breakout- full calibration freezes sensor (Read 2797 times) previous topic - next topic


Geez, no explanation from the OP at all, and here I am a year later, experiencing the exact same thing. Code worked fine on my last board and I have a new board layout that *seems* to have the same connections => on the new layout the Adafruit BNO055 worked perfectly until I got calibration complete, and then suddenly all values became 0.0625, and upon restart the board is not responding on I2C at all.

OP (Tuskiomi): if you are receiving notifications, please consider this an invitation to provide more detail about the connection issue that led to this problem. :)


I'm having the same issue too with the same values even. Did anyone ever find out what this issue was?


Ok so I think its probably a wiring issue as the op originally mentioned. I had just over a foot of unshielded wire leading to my bno055 breakout and was not aware of the issues with i2c over longer cables. I found this article (link below) describing the issue, which specifically mentions the bno055. I'll be implementing the differential i2c solution and report back if that fixed my problems.


Go Up