Go Down

Topic: ESP8266FS will not work (Read 484 times) previous topic - next topic


Sep 11, 2019, 09:38 pm Last Edit: Sep 12, 2019, 02:07 am by Joelaw
I installed per instructions the ESP8266FS tool and I can see it in the  'tools' folder but it does not show up under the tools menu in the IDE as a choice?  Tried re-installing several times but no difference.  It worked OK on my old computer system.

I am working on a program by RUI SANTOS for using the ESP8266 SPIFFS function to download html and css data into the ESP8266 unit in SPIFFS.

Anybody know what I am doing wrong?

Joe L.


I can see it under 'tools' but it does not show up under tools?
Make up your mind!  >:(
Mrs Drew
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.


Make up your mind!  >:(
I have further clarified my statements in my post.  It should be installed into the Arduino "tools" folder and when the "tools" menu choice is clicked, there is supposed to be a choice for "ESP8266 sketch data upload".  This tool should download a html and a css file into the ESP8266 SPIFFS memory instead of using an SD card to display the data in a browser.



Make sure it's installed in the correct location. The folder structure should look like this:

{sketchbook folder}

You can find the location of your sketchbook folder in the Arduino IDE at File > Preferences > Sketchbook location.

I just installed the latest version of ESP8266FS (0.4.0) and it shows up as Tools > ESP8266 Sketch Data Upload in Arduino IDE 1.8.9.


I have done that.  I removed the .jar extension and get the same result.  The file is in the right place but does not shoe up in the tools menu as a function to act on.  Cannot load "data" files into SPIFFS?



I removed the .jar extension and get the same result.
Don't do that.

Cannot load "data" files into SPIFFS?
What do you mean by that?

Go Up