Go Down

Topic: Help ARDUINO NANO [RISOLTO] (Read 119 times) previous topic - next topic

bazzo54

Sep 18, 2019, 05:37 pm Last Edit: Sep 19, 2019, 10:44 am by bazzo54
Salve a tutti ... ho un problema di collegamento trasferimento programma con un Arduino Nano con AtMega328P

Sistema operativo WIN10 64 bit ultima relaise

Arduino IDE 1.8.9

Porta COM  USB-SERIAL CH340 (com5)

scheda selezionata " Arduino Nano "
Processore AtMega328P

errore :

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x93
avrdude: ser_send(): write error: sorry no info avail
avrdude: ser_recv(): read error: Accesso negato.


Chi mi può dare una mano per risolvere questo Problema ?

Grazie !!!






Federico66

In base all'errore non saprei dirti, ma essendo una Nano, hai provato con processore ATmega328P (Old Bootloader)?

Federico
"La logica vi porterà da A a B. L'immaginazione vi porterà dappertutto." A. Einstein

bazzo54

Grazie Federico di avermi risposto

Si ho provato con ATmega328P (Old Bootloader) ma nulla e cambiato ... ho provato con altri moduli ma il problema persiste ...

Mi e venuto in mente che Fosse IDE che non funzionasse con il nuovo aggiornamento di WIN10 ed ho programmato un arduino Due e questo e andato a buon fine.

Che casino !!


Federico66


Sei sicuro dei driver per CH340?

Prima funzionava?


Federico
"La logica vi porterà da A a B. L'immaginazione vi porterà dappertutto." A. Einstein

Davide02

Buongiorno,

Ha provato a cambiare la porta COM dell'arduino nano?

Davide

bazzo54

Sei sicuro dei driver per CH340?

Prima funzionava?


Federico

Buongiorno Federico

Bravo hai toccato un punto dolente dei dubbi che ho ...che sia questo il problema che questo driver non funzioni e da qualche anno che non usavo Arduino Nano e nel fra tempo ho cambiato il Pc ... ultimamente sto utilizzando Arduino Due e tutto funziona ho fatto la prova prima di postare qui !!!... se hai un link da mandarmi per sostituire il driver che sto utilizzando CH340 lo sostituisco cosi mi tolgo il dubbio.

Grazie Maurizio


Federico66

Prova da qui.

Altra questione, visto che usi W10, e ne ho sentito parlare molto da queste parti,
l'IDE Arduino che usi è scaricato dall'AppStore?
Se si, disinstalla e usa la versione portable dell'IDE, segui questa guida


Facci sapere
Federico
"La logica vi porterà da A a B. L'immaginazione vi porterà dappertutto." A. Einstein

bazzo54

Prova da qui.

Altra questione, visto che usi W10, e ne ho sentito parlare molto da queste parti,
l'IDE Arduino che usi è scaricato dall'AppStore?
Se si, disinstalla e usa la versione portable dell'IDE, segui questa guida


Facci sapere
Federico
Ottimo Federico !!!

Il driver che mi hai linkato funziona perfettamente ... per programmare il Nano ho usato la versione ATmega328P (Old Bootloader) ed e andato a buon termine e controllato in funzionamento ... era proprio il Driver che aveva problemi !!!

Grazie ancora Federico...caffe pagato !!

Maurizio

Federico66

Il driver che mi hai linkato funziona perfettamente ...
Benissimo, è sempre un piacere sapere di essere stato utile :)


Federico

PS
Per favore, modifica il tuo primo post anteponendo [RISOLTO] al titolo
"La logica vi porterà da A a B. L'immaginazione vi porterà dappertutto." A. Einstein

Go Up