Go Down

Topic: UPLOADING PROBLEM WITH ESP32 (Read 2011 times) previous topic - next topic


Hi guys, my first time working with the ESP32 DevKit V1. i just tried the "hello world" program, no problem when it compiled but whenever uploading, this error messages showed up:

esptool.py v2.6
Serial port COM8
Traceback (most recent call last):
  File "esptool.py", line 2959, in <module>
  File "esptool.py", line 2952, in _main
  File "esptool.py", line 2653, in main
  File "esptool.py", line 460, in connect
  File "esptool.py", line 440, in _connect_attempt
  File "esptool.py", line 379, in sync
  File "esptool.py", line 322, in command
  File "esptool.py", line 285, in write
  File "site-packages\serial\serialwin32.py", line 323, in write
serial.serialutil.SerialTimeoutException: Write timeout
Failed to execute script esptool
An error occurred while uploading the sketch

i have already tried to restarting, reinstalling, etc,...

please help!! thanks alot!!!


When you plug in your ESP32 to your PC, do you hear a sound? If not, try a different USB cable.
    Does Windows say anything about installing drivers failed? You might need to manually install the drivers.
    If you open the device manager of windows are there any USB devices listed (after you plugged in the ESP32) that have no drivers installed? Then you most likely need to manually install FTDI (USBtoSerial) drivers.
    I needed to install separate drivers for the onboard USB of my ESP32. In my case it was for a CP2102 chip. You can find the drivers here: ESP32.net.
    Did you try to use a different USB cable?

And last, some ESP32 boards need to be set manually into bootloader mode. On my board that would be pressing the RESET button and keep it hold, then press the USR button and keep it hold, then release the RESET button, then release the USR button. Might be different for your board.

Please avoid private messages, your question may be someone's answer in the future!

Go Up