Go Down

Topic: Arduino environment error message when trying to update Arpie firmware (Read 580 times) previous topic - next topic

fifthera

Hi

I'm trying to update my Arpie MIDI arpeggiator with the latest firmware, 5.9beta, following these instructions:
http://www.six4pix.uk/arpie/update.html

No matter what I try I get this:

dyld: Symbol not found: _unlinkat
  Referenced from: /Applications/Arduino.app/Contents/Java/arduino-builder
  Expected in: flat namespace

/Applications/Arduino.app/Contents/Java/arduino-builder returned 133

Error compiling for board Arduino Duemilanove or Diecimila.


Please, can anyone help with this? What does it mean?




pert

Just a wild guess, but try closing all Arduino IDE windows, start the Arduino IDE again, and then try another update. That will clear the compilation cache, which might have gotten corrupted.

fifthera

This is what I've tried:

-different updates: 5.8, 5.9 and 5.10
-doing the update from the arduino web editor as opposed to the app (btw had to download the older version of the app as I am on MacOS 10.9.5)

Mostly I just get that same exact error message, except the web editor did once or twice give other log messages that seemed positive, like it was working, but my Arpie's firmware is still the same. Some of those messages mentioned the code containing a mix of two different (incompatible?) libraries causing ... something???


Some of the instructions are also unclear: one version says to press the Arpie reset button before clicking Upload, another says to do it right after. Don't know if it makes a difference.

Obviously, any tips from Arpie users would be greatly appreciated. Is anyone else having trouble updating their Arpie?

Go Up