Go Down

Topic: Queima de i/o (Read 141 times) previous topic - next topic

Megalopole

Preciso de ajuda, desenvolvi um sistema de automação para minha casa, onde todas as lâmpadas seriam acionadas por interruptores normais, onde o estado da lâmpada muda sempre q muda o botão, pois haverá tbm o acionamento pelo smartfone.
Acredito q a programação não é importante para meu problema, o arduino irá controlar 20 pontos de iluminação através de relés, então tenho 20 output e 20 input, levei toda a fiação para um quadro central onde está os dispositivos, o que aconteceu é que quando liguei parte do fiação, queimou duas entradas e duas saídas, as entradas morreram completamente e as saídas uma fica sempre em 1.4v e outra 3.4v. Agora estou com medo de trocar o arduino e queimar tbm esse, em pesquisas imagino q possa haver algo de problema com as entradas, pois configurei como pullup, então sempre q acionou o botão é aplicado 0v, esse 0v vem diretamente da fonte, será que como tenho várias entradas recebendo 0v isso pode estar sobrecarregando os resistores do arduino??

bubulindo

Como ligaste isso tudo?

5V não dá para grandes extensões de fio...
This... is a hobby.

Megalopole

Em uma fonte de 2A, tentei primeiro ligar no GND e depois no +5v aconteceu o mesmo problema, o estranho é q foi apenas nos pinos em um dos interruptores, os outros funciona normal, tipo o input do 32 danificou a output 31, pq depois mudei esse da 32 para a 48 e danificou a output 47, essas duas output danificadas ficam sempre próximo de 0v.

bubulindo

Eu perguntei como ligaste... não onde ligaste. Um esquema da ligação serve.
This... is a hobby.

Megalopole

Basicamente é a forma q segue em anexo, porém com 20 chaves em entradas diferentes e 20 relés.

tecdiego

Megalopole já deu uma pesquisada para saber quanto o arduino consegue (suporta) ?
Esse pode ser o seu problema.

Megalopole

Sim, e não deve ser o problema, pq os reles são com optoacopladores, o consumo é mínimo.

bubulindo

Sim, e não deve ser o problema, pq os reles são com optoacopladores, o consumo é mínimo.
Isso é assumir bastante... qual é o optoacoplador que vais usar? O motivo pelo qual pergunto é que o Arduino não consegue fornecer assim tanta corrente dos pinos de saída para teres um porto inteiro ligado ao mesmo tempo.

Não digo que seja impossível, mas se for com módulos comprados na internet, duvido que eles tenham tido isso em atenção. Logo é bom pesquisares quais os componentes e corrente que vai ser consumida.
Claro que, da mesma maneira que dimensionas o cabo de alimentação para um projecto, podes também desenhar um sistema de forma a que apenas algumas luzes estejam ligadas ao mesmo tempo. Mas não me parece fácil fazer isso.
This... is a hobby.

Megalopole

Problema resolvido, o circuito estava sofrendo indução dos cabos de força. Usei outros relés para acionar as entradas do arduino.

Go Up