Go Down

Topic: DigiSpark Pro ATtiny167 "Device not recognized" what am I missing (Read 313 times) previous topic - next topic

Jackflash

Hi,
           I'm frustrated I feel like I am 90% there but my computer will not recognize the ATtiny167. Here i9s the list of things I have completed/tried using Windows 10 and Arduino 1.8.6;

                           
                      1) Installed Driver USB Bootloader is complete
                      2) Device Management I see the device
                      3) Arduino Sketch select 16.5 MHz board in parameters
                      4) Led on the board flashes sound beeps and stops flashing
                      5) "Device not recognized"
                      6) I have rebooted many times. I deleted everything and started over again with same       
                          results
                      7) Used a 3rd party software to look at my USB ports it see the device
                      8) I have tried more than one device as well

             I'm stuck at this point. I've tried running example programs however the device is not recognized.

Any suggestions?

DrAzzy

It sounds like you're using the Digispark Pro with the t167?

That is a very different matter than just using the t167 straight up.

Please confirm?
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

Jackflash

Yes, I am using the Digispark Pro ATtiny167.

Jackflash

#3
Sep 22, 2019, 12:11 am Last Edit: Sep 22, 2019, 12:14 am by Jackflash
Hi, I went back and carefully read through the instructions again and changed it to 16MHz the flashing program now downloads to the ATtiny167. So I am able to change the flashing rate. However, I am not able to get rid of the error message with Windows 10 saying the USB Device is not recognized. Any suggestions?


Here is the link to the instructions I am directed to use. I also updated the Topic for future reference.

https://digistump.com/wiki/digispark/tutorials/connectingpro

Go Up