Go Down

Topic: Error updating to Arduino 1.8.10 (error: duplicate 'inline') Arduino 1.8.9 works (Read 3792 times) previous topic - next topic

rtek1000


I use the portable folder:

https://www.arduino.cc/en/Guide/PortableIDE

I did a test, copied only the SAM and STM32F1 files to Arduino IDE 1.8.10, and was able to compile only once, the second time this same error occurred.

Do I need to reinstall all hardware supports again, and delete the portable folder, STM32F1, STM32F4, ESP32, ESP8266, SAM etc?

Code: [Select]

C:\Arduino IDE\arduino-1.8.10\portable\sketchbook\hardware\Arduino_STM32\STM32F1\system/libmaple/stm32f1/include/series/gpio.h:489:15: error: duplicate 'inline'
 static inline __always_inline void afio_exti_select(exti_num exti, exti_cfg port) {
               ^~~~~~~~~~~~~~~
C:\Arduino IDE\arduino-1.8.10\portable\sketchbook\hardware\Arduino_STM32\STM32F1\system/libmaple/include/libmaple/nvic.h:112:15: error: duplicate 'inline'
 static inline __always_inline void nvic_globalirq_enable() {
               ^~~~~~~~~~~~~~~
C:\Arduino IDE\arduino-1.8.10\portable\sketchbook\hardware\Arduino_STM32\STM32F1\system/libmaple/include/libmaple/nvic.h:119:15: error: duplicate 'inline'
 static inline __always_inline void nvic_globalirq_disable() {
               ^~~~~~~~~~~~~~~
C:\Arduino IDE\arduino-1.8.10\portable\sketchbook\hardware\Arduino_STM32\STM32F1\cores\maple/ext_interrupts.h:109:15: error: duplicate 'inline'
 static inline __always_inline void interrupts() {
               ^~~~~~~~~~~~~~~
C:\Arduino IDE\arduino-1.8.10\portable\sketchbook\hardware\Arduino_STM32\STM32F1\cores\maple/ext_interrupts.h:123:15: error: duplicate 'inline'
 static inline __always_inline void noInterrupts() {
               ^~~~~~~~~~~~~~~
C:\Arduino IDE\arduino-1.8.10\portable\sketchbook\hardware\Arduino_STM32\STM32F1\system/libmaple/stm32f1/include/series/spi.h:78:15: error: duplicate 'inline'
 static inline __always_inline void spi_gpio_cfg(uint8 as_master,
               ^~~~~~~~~~~~~~~
Please avoid private messages, your question may be someone's answer in the future!

pert

I did a test, copied only the SAM and STM32F1 files to Arduino IDE 1.8.10, and was able to compile only once, the second time this same error occurred.
If you close all Arduino IDE windows, restart the Arduino IDE, then compile again, do you get the same behavior of the first compilation being successful, then erroring after that?

rtek1000

Hello, after closing the windows and opening again, it is not possible to compile again, as if any files had been modified incorrectly the first time the compilation was successful.

I am currently using IDE 1.8.9 again, I will skip version 1.8.10. Next time (1.8.11) I try to update again. Thanks.
Please avoid private messages, your question may be someone's answer in the future!

dennymoney

I have this issue also.
I tried installing 1.8.10 several times. No luck. Will not compile without tons of errors.
I am using 1.8.9 and there are no errors at all.
I even installed 1.8.10 on another machine thinking there was a problem with this machine.
the same problem.
I will wait for 1.8.11 and hopefully they will get it fixed.
1.8.9 works great so no worries.


rtek1000

Hello,

I would like to inform you that after deleting everything and installing again from scratch, downloading all board holders again, the IDE became usable.

There was a crash while editing the preferences, and I had to finish the Java process to be able to close the window, but after that there were no more problems.
Please avoid private messages, your question may be someone's answer in the future!

Go Up