Go Down

Topic: Problems with PZEM004T (Read 105 times) previous topic - next topic

Klausi1967

Hello to Everyone,

thanks for running such a nice forum and putting all the effort into it.

I do have problems getting the communication between an Arduino Nano and a PZEM004T to work.

I have used sketches from the web and I have written my own, none works.

With both sketches, I see the correct bit stream arriving on the Rx of the PZEM004T (using the osci), but it does not answer.

I have tried via a USB to Uart bridge directly from HTerm out of the PC, but it still does not respond. Hex transmission = B0 C0 A8 01 01 00 1A


The red power LED on the PZEM004T shines red and the voltage at the output of the LDO is ~3,3V. Input voltage is about 100VAC.

Current transformer is connected to the PZEM004T, but no current is running through it at the moment.

I have tried 1 and 2 stop bits without success (8N1 and 8N2).

I'm at my wits end. Please help!
I can post my sketches, but as the bit stream arrives at the Rx, I believe the problem is rather somewhere else.

Thanks in advance.

BR

Klausi1967

Wanted to add, baud rate = 9600

Go Up