Go Down

Topic: Arduino not recognised by the computer (Read 97 times) previous topic - next topic

Macgomes

Hello everyone,,
I got my Elegoo UNO R3 about a month ago (so a refund is not an option) and used it for a while. It worked flawlessly. Today, when I plug it in it just doesn't get recognized by my pc (Windows 10 x64). I have tried literally everything: reinstall drivers, change the ATMega328p-U chip, clicking the Reset button, changing the cables but NOTHING worked for me!!! It won't be recognized by my computer!

Any help?
nsw driving test

RogerIrwin

The USB interface is implemented with another microcontroller, a ATMega16U2.

This is the device that windows will recognize as a serial port, even if your main micro controller is not working.

If you look at the Hardware devices list on windows you should always see the USB device even if the driver is not installed or correct....it will appear as an unknown device, possibly with a graphic ? next to it.

If that is the case, then you need to look at drivers.

If nothing changes on the USB hardware list when you plug it in then the USB interface is up the creek. You could try reprogramming the USB controller (ATMega16U2):

https://forum.arduino.cc/index.php?topic=111.0





Go Up