Go Down

Topic: Nano mit Android betreiben (Read 818 times) previous topic - next topic

Jan999

Moin!

Ich möchte an einem Android einen Nano ausprobieren.

Als Editor abe dabei ArduinoDroid installiert. Beim Versuch das Sketch aufzuspielen bekomme ich die Meldung, dass der Nano nicht gefunden wird. Im Troubleshooting steht was von erforderlicher Stromversorgung.

Kann mir einer sagen, wie das sinnvoll machen kann?

Jan

HotSystems

Ich vermute, da fehlt der passende USB-Treiber.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

postmaster-ino

Jesses ... jetzt habe ich doch tatsächlich 'An einem Arduino einen Nano' gelesen ...

Hatte mich schon gewundert ... netter Freudscher eigentlich :)
anscheinend ist Es nicht erwünscht, einen Foren-internen Link als 'Homepage' einzubinden, damit JEDER nur einen Klick von combie's Liste zum Thema State-Maschine entfernt ist.
... dann eben nicht ...

Jan999

An meinem Windows Aduino-Editor müsste ich auf "Old Bootloader" umstellen.

Kann es dass sein?

Aber wo am ArduinoDroid?

Jan

uxomm

Nun, "Nano" ist ja mittlerweile ein recht dehnbarer Begriff. :)

Um was für einen Nano handelt es sich?
Bitte Link zum Produkt.

btw
Wenn man sich die Rezensionen zu ArduinoDroid so durchliest, dann entsteht zumindest bei mir der Eindruck, dass es ein großer Glücksfall ist, wenn damit irgendetwas funktioniert :)
Always decouple electronic circuitry.

Jan999

#5
Oct 21, 2019, 10:17 pm Last Edit: Oct 21, 2019, 10:19 pm by Jan999
https://www.ebay.de/itm/3x-Nano-V3-0-Arduino-Kompatibel-ATmega328-5V-Board-CH340G-USB-Chip/252852557403?ssPageName=STRK:MEBIDX:IT&_trksid=p2057872.m2749.l46252&redirect=mobile

In den Settings hatte ich "Nano w / ATmega328 / CH340G" aktuell gesetzt.

Gruß Jan

wapjoe

Jesses ... jetzt habe ich doch tatsächlich 'An einem Arduino einen Nano' gelesen ...

Hatte mich schon gewundert ... netter Freudscher eigentlich :)
Ging mir genauso, erst beim 2-3. Drüberlesen dämmerte es mir! :D
Ich hoffe mein Schaden hat kein Gehirn genommen!

- Homer S.

Jan999

#7
Oct 22, 2019, 05:12 am Last Edit: Oct 22, 2019, 06:53 am by Jan999
Ging mir genauso, erst beim 2-3. Drüberlesen dämmerte es mir! :D
Eines wollte ich noch ergänzen. Normalerweise leuchtet mit dem Stromanschluss über USB immer eine LED auf dem Board. Bei der Verbindung mit dem Android nicht. Deshalb vermute ich mehr oder weniger das es ein Stromproblem ist.

... und wie komme ich nun weiter?

Jan

gregorss

#8
Oct 22, 2019, 07:14 am Last Edit: Oct 22, 2019, 07:14 am by gregorss
Ich habe die URL zum Fernost-Nano mal klickbar gemacht - und kürzer.

... und wie komme ich nun weiter?
Bitte poste auch einen Link zur Software.

Gruß

Gregor

„Ich glaube, ich leg' mich noch mal hin", sagte das Bit.

HotSystems

Eines wollte ich noch ergänzen. Normalerweise leuchtet mit dem Stromanschluss über USB immer eine LED auf dem Board. Bei der Verbindung mit dem Android nicht. Deshalb vermute ich mehr oder weniger das es ein Stromproblem ist.

... und wie komme ich nun weiter?

Jan
Wenn es tatsächlich ein Spannungs oder Stromproblem ist, brauchst du ein USB-Kabel, bei dem die 5Volt Spannungsleitung aufgetrennt ist und ein zusätzliches 5Volt Netzteil für den Nano.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Jan999

Moin!

5Volt - bist Du sicher?

Das Kabel in der Art was ich kenne hat auf der einen Seite 2 USB und einen für den Arduino.

Dann werden doch über den USB doch nur 3,5Volt geliefert.

Oder liege ich falsch?

Jan

uwefed

#11
Oct 22, 2019, 10:26 am Last Edit: Oct 22, 2019, 10:26 am by uwefed
Quote
5Volt - bist Du sicher?

Das Kabel in der Art was ich kenne hat auf der einen Seite 2 USB und einen für den Arduino.

Dann werden doch über den USB doch nur 3,5Volt geliefert.

Oder liege ich falsch?
Welches besondere Kabel hast Du?

2 Stecker auf einer Seite kenne ich nur von alten externene 2,5" HDs (da sind es Typ A) damit der Strom von 2 USB Buchsen abgezogen wird und dann ist bei einer die Datenleitungen nicht bestückt.
Oder von Kabeln die 2 verschiedene Stecker haben, damit man sie universell einsetzen kann.

Beide Kabeltypen sind nicht USB-Normgerecht.

Besorg Dir mal einen einfachen richtigen Kabel und dann reden wir weiter.

Grüße Uwe

HotSystems

Moin!

5Volt - bist Du sicher?
Nee, woher. Ich kenne dein System nicht, dein Tablet erst recht nicht.
Aber Standard sind 5 Volt.
Wenn du es nicht glaubst, einfach mal nachmessen, das macht schlauer.

Quote
Das Kabel in der Art was ich kenne hat auf der einen Seite 2 USB und einen für den Arduino.

Dann werden doch über den USB doch nur 3,5Volt geliefert.

Oder liege ich falsch?
So ein Kabel kenne ich nicht.
Bei meinen kommt immer 5 Volt raus.

Also nochmal nachmessen.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Jan999

Tablet ist ein Samsung Galaxy (2016)

Jan

HotSystems

Tablet ist ein Samsung Galaxy (2016)

Jan
Ok....das ist auch nur ein Name, deswegen kenne ich es doch nicht.
Und da werden sicher auch 5 Volt rauskommen. Aber nachmessen ist sicherer.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Go Up