Go Down

Topic: Arduino Maxmsp Serial Conflict (Read 494 times) previous topic - next topic

Moris526

Hi all.

Here is the thing.

If i open a patch, then  plug the arduino uno board via usb, and then open Serial object, evething works fine.
But if a have the arduino pluged in and then open the patch, i cant open serial port:   ¨Error opening serial port¨.

Ive try delaying the opening of the port a few seconds, but doesnt seem to be a timing thing.



Any  idea helps

Thnaks.

pert

i cant open serial port:   ¨Error opening serial port¨.
Are you getting this error in Max MSP or in the Arduino IDE?

Moris526


In fact is in Max for Live, Max MSP for Ableton Live

Moris526


More data


With Arduino Pluged in.  If I load a patch with  ¨Serial c 9600¨  Gives error,  but....


If I create a new patch and create the Serial object, then it connects..

Moris526

Correction:


When i load the patch it opens the port.  When I open the patch to edit it disconects the serial

sterretje

Are you talking about https://cycling74.com/. If so, there is a Max forum that might be able to help.


When i load the patch it opens the port.  When I open the patch to edit it disconects the serial
Not familiar with that software. After disconnection, it can't connect any longer till you close the patch and load it again?
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

Go Up