Go Down

Topic: Arduino IDE can't find .../java/bin/java. [Solved] (Read 226 times) previous topic - next topic

ModbusMan

Nov 11, 2019, 11:43 pm Last Edit: Nov 16, 2019, 10:13 pm by ModbusMan
I installed Arduino IDE v1.8.9 for linux, 64 bits on the Raspbian desktop (Sept. 2019 version. When I start the IDE using the icon added to the Raspbian programming menu then nothing happens apart from a spinning hourglass for a few seconds. If I run the arduino script which the icon is linked to directly in a terminal window then I see the following:

./arduino: line 35: /home/pi/Downloads/arduino-1.8.9/java/bin/java: No such file or directory

The java file in the bin directory exists.

pi@raspberry:~/Downloads/arduino-1.8.9/java/bin $ ls -l
total 448
lrwxrwxrwx 1 pi pi      8 Oct  6  2018 ControlPanel -> jcontrol
-rwxr-xr-x 1 pi pi   8464 Oct  6  2018 java

I also tried IDE v1.8.10 and the same issue occurs. Anybody got any idea's?

Poki

Raspbian is a 32-bit Linux OS so try the ARM 32-bit version of the IDE. I do not think the ARM 64 version of the IDE works on Raspbian.

ModbusMan

Sorry, I got slightly mixed up with the names...
I'm using the Raspberry Pi Desktop OS for PC (in a VMware environment), rather than the Raspbian desktop. The version of Arduino IDE is the regular Linux 64 bit version, not the Linux ARM variant.

Poki

Try the 32-bit IDE. Or dig into the details by examining the output of `file /bin/bash'`. If it says "ELF 32-bit" and/or "i586/i686", the OS is running 32-bit executables.

Even if you have 64-bit hardware, the OS may be running in 32-bit mode. 64-bit code will not run on a 32-bit OS.

ModbusMan

Hi Poki,

I installed the Linux 32 bit version of the IDE and bingo, it worked!!  :)  Seems like the Raspberry desktop PC is a 32 bits os.
Thanks for the tip.

Go Up