Go Down

Topic: HC-05 VERSION:4.0-20190815 datasheet ?? (Read 329 times) previous topic - next topic

Hp9000

HI,
Has someone a HC-05 VERSION:4.0 datasheet?

AT+INIT --> Init SPP profile mode does't works and return an ERROR:[0] !!!!

Usualy i use HC-05 VERSION:2.0 without problems and probably 4.0 version has different behaviour, but i have not found documentation.


Thanks!







 

Nick_Pyner

It may mean that the profile is already loaded, which would hardly be surprising. Also, I understand that the more obscure commands are not accessible by merely pushing the button, and you need to apply power to the EN pin. There may be something to this effect on the Martyn Currey website.

Hp9000

Hi,
i have been powered EN pin (34) to high level for program mode.

HC-05 v4 execute commands like AT+NAME=xxxxx or AT+ROLE=1 and AT+CMODE=0, but not  AT+INIT.
 Another detail is that EN pin (34) need to a higher voltage level, 3.3 is too LOW.

I need to a datasheet V4.00,all Martyn Currey posts talks about 2.0 version.


Another thing I don't understand is  ERROR:[0], if i'm not mistaken is a syntax error.



Thank's
 




Nick_Pyner

#3
Nov 12, 2019, 01:37 am Last Edit: Nov 12, 2019, 01:45 am by Nick_Pyner
I'm not sure there is such a thing as an HC-05 v4 and, if there was, I'm pretty sure Currey would know about it. I alluded to his site because he refers to the more obscure commands for HC-05, and I have never heard of the INIT command. He also has information about BT4. This may be merely a matter of nomenclature, and I think you need to be more forthcoming about what you are actually holding in your hand. Counting the black LSI chips on the board might be a good place to start.

Hp9000

Hi,
thanks for your concern,in this post subject i attached real AT+VERSION response of my HC-05.
VERSION:4.0-20190815 was the response and that is the difference with my other BT devices.

Now is 02:36 AM in Italy and i'm tired.This situation is not critical for me because i have been understood the reason and i can buy only HC-05 V2 versions,but i'd like to understand the V4 version.



Tomorrow i'll try to send a message to Currey.

 

Thanks!


Nick_Pyner

#5
Nov 12, 2019, 04:09 am Last Edit: Nov 12, 2019, 04:10 am by Nick_Pyner
AT+VERSION response of my HC-05.
VERSION:4.0-20190815 was the response
OK, well, that proves my concerns were unfounded..........

And it's a nice sunny afternoon here in Australia.

I bought such modules in China.
HC-05 VERSION: 4.0-20190815. It's a fake copy.
AT + INIT ERROR:

AT + SENM = 2,3 ERROR:

A memory chip is installed for decoration. This is a relabeled other chip. Having removed it, I did not affect the operation of the module and found that all contact pads were closed.
Discard 60 modules.

Go Up