Go Down

Topic: Nieuw in arduino (Read 3581 times) previous topic - next topic

brentfraters

Nov 27, 2019, 07:03 pm Last Edit: Nov 28, 2019, 04:09 pm by brentfraters Reason: meer informatie
na wat zoek werk heb ik hier betere informatie voor het probleem.

gebruikte onderdelen

-Arduino uno (bangood)
-DC motor 3V-6V
-Motor driver shield L293D
-Female to Female wires
-DC 7.4V 2slot voor 18650 batterij
-Stekker:INPUT 200-240V~ OUTPUT +12V   50/60Hz   0.4A MAX   1.5A     18W MAX


mijn plan was eerst om een auto te maken die een lijn volgde deze had ik helemaal gemaakt, programma geüpload op de arduino maar dit wou niet werken dit terug uiteen gehaald en terug van 0 begonnen voor te testen.

-Arduino UNO aangesloten op computer met USB, programma BLINK geüpload. Dit werkte allemaal perfect. Oranje led knipperde om de second.

-2de stap was dat ik een motor ging aansluiten via het motor shield. Dus zo gezegd zo gedaan, arduino losgekoppeld van laptop, motor via de female to female wires aangesloten naar het motorshield (uiteindes heb ik gestript 1 kant op de motor gesoldeerd andere kant draadjes bijéén gedraaid en vast geschroeft in motor shield) dit was allemaal klaar dus arduino terug aan de laptop gehongen programma geïnstalleerd maar hier gebeurde niets volgende poging dan maar MOTOR2 gedaan hier gebeurde ook niets dus terug het programma voor MOTOR1 geïnstalleerd dit wou weer niet werken dus besloot ik een stekker te zoeken voor in de arduino te hangen dat hij niet alleen op de laptop was aangesloten. Stekker gevonden alles klaargemaakt maar dit bleek ook niet te werken. na dit allemaal besloten de lampjes TX,RX,L niet meer te branden dat ik deze op de laptop aansluit enkel de ON knop brand nog groen, laptop vind de arduino ook niet meer. wat deed ik fout?

ik hoop dat ik genoeg info heb gegeven alvast bedankt voor mee te zoeken naar de fout.

Alvast bedankt.

MAS3

Hoi brentfraters, welkom !


Arduino is bedoeld om programmeurs wat beter met elektronica bekend te maken, en elektronici met programmeren.
Maar ook als je van beide nog niet veel kaas gegeten hebt kan je met Arduino best wat leren.
Ik heb geen idee wat van bovenstaande op jou van toepassing zou kunnen zijn, misschien kun je daar wat meer over vertellen ?

Je vertelt heel globaal wat je allemaal geprobeerd hebt.
Maar dat betekent dat je geen details geeft.
Nogal dunne draden is bijvoorbeeld onduidelijke informatie.
En batterijen zijn er in vele soorten en maten, die allemaal geschikt zijn voor andere doelen.
Veel (dus niet alle) motorshields werken met onderdelen die een nogal grote spanningsval veroorzaken.

Stel je gaat met zo'n shield een 6 volt motor aansturen en voedt dat met 2 AA alkaline batterijen.
Zo'n batterij levert 1.5 volt en 2 stuks samen dus 3 volt.
Daarmee zou je een 6 volt motor eventueel wel kunnen laten draaien, maar niet erg snel en je kunt dit ook niet erg belasten.
Maar de onderdelen op je shield verbruiken waarschijnlijk zelf ook wat spanning (deze bewoording klopt niet helemaal, maar het is wel het effect dat het heeft), en dat komt dan waarschijnlijk wel erg dicht in de buurt van die 3 volt.
En dan blijft er dus niets meer over voor je motor.

Maar of dit voor jou ook precies zo uitkomt weet ik natuurlijk niet want de door mij genoemde details zijn door jou niet ingevuld, behalve de 2 voor het aantal batterijen.

Met andere woorden, om jouw vraag van een passend antwoord te kunnen voorzien, is het nodig dat je alle details noemt.
Anders blijft het gokken wat er aan de hand is.

Wat je in ieder geval nooit moet doen, is de motor via een motorshield voeden uit de Arduino en/of een USB aansluiting.
Meer dan 9 van de 10 gevallen zal de USB aansluiting overbelasten en bijna 100 % van de gevallen zal de voeding van de Arduino zelf overbelasten (op meer dan 1 manier).
Dat is ook het bestaansrecht van een motorshield, en waarom dat ding een aansluiting voor een externe motorvoeding heeft.
Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

brentfraters

Beste

Ik ben totaal nieuw in deze wereld van elektronica/programmeren.

-Voor de motor aan te sluiten op het motorshield heb ik gebruik gemaakt van female to female wires  en deze uiteinden gestript zodat ik deze op de motor kon solderen en kon aansluiten op mijn motorshield.

- Als externe voedings bron heb ik een batterij houder (7.4V voor 2 18650 batterijen) besteld en hier zelf een schakelaar op geïnstalleerd  de batterijen zijn 3.6V 3500 mah

-De motors zijn de volgende: DC 3-6V gear motor TT

Het voorval dat mijn orange lichtjes niet meer werkte is nadat ik de arduino aan het stopcontact heb gehongen  met een adaptar.

Ik hoop dat dit genoeg informatie is om een antwoord te kunnen geven.

Alvast bedankt

MAS3

Dat is nog steeds niet alle mogelijke informatie, maar wel wat meer.
O, ik zie nu dat je ook de informatie in je eerste post hebt aangepast.


De L293D is een heel beperkte motordriver.
Die heeft met zekerheid last van de eerder genoemde spanningsval, en die loopt relatief hoog op.
Van de 7,4 volt blijft met veel mazzel nog maar 6 volt over, maar dat zou voldoende moeten zijn voor de motor die je gekozen hebt.
Deze motordriver kan maar 600 mA leveren, en als je zorgt dat ie heel goed gekoeld word kan je dat nog opvijzelen naar 1 Ampère.
Hoeveel heeft die motor van je nodig ?
Een motor die nog moet starten, heeft 6 tot 10 maal zoveel stroom nodig als er op het typeplaatje staat vermeld.
En dan gaat de vraag rijzen of die L293D dat wel kan leveren.

Quote
INPUT 200-240V~ OUTPUT +12V   50/60Hz   0.4A MAX   1.5A     18W MAX
Dat is niet duidelijk.
Moet dat niet zijn:

Code: [Select]

INPUT 200-240V~ 50/60Hz   0.4A
OUTPUT +12V  MAX  1.5A  18W MAX


?

En waar heb je die op je Arduino aangesloten ?
Plus en min niet omgedraaid ?

Je moet bij voorkeur niet je Arduino op dezelfde voeding aansluiten als je motorshield.
De meeste motorshields hebben een eigen voedingsaansluiting, maar of dat ook zo is bij de L293D varianten weet ik niet.

Ik vermoed dat er een onderdeel op je Arduino kapot is gegaan.
Of dat rendabel te repareren is weet ik niet, want Uno's van leveranciers zoals Banggood zijn over het algemeen zeer goedkoop.

Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

shooter

niet gelijk in paniekstand gaan, maar gewoon opnieuw beginnen, en het is maar de vraag of de L293 netjes zijn werk doet bij een lage motor spanning, en dat is moeilijk vast te stellen als het draait.
en maakeen schema zodat je kunt zien waar de spanning overal staat en waar de stroom loopt.

paul deelen
shooter@home.nl
making controls with codesys PLC and arduino

Go Up