Go Down

Topic: uno will not upload (Read 237 times) previous topic - next topic

Pfroment

i received my uno yesterday and was trying to upload the sample blink program/

I get "avrdude: ser_open(): can't set com-state for "\\.\COM3"  error message.   I researched  the post on the forum  and on you tube.   I did everything suggested to no avail.    i even tried the uno on an old vista laptop  and it also would not upload either.   Did i miss something or do i have a defective board?

help please  paul f

(deleted)


Pfroment

sorry about that,   if have the uno with amega328p u chip.   installed the ide program,  plugged in the uno
It setup com 3.   in the tools both the correct board and com port is selected.  in the file/ preferences  the upload is checked and the compilation is not.   the scetch compiles ok ,  but i keep getting the above error message.     i have tried different usb ports, rebooting , resetting uno, uninstalling the program and reinstalling.   updated the com 3 driver.     i have read every post pertaining to this problem and followed all the suggestions.  I even went on utube and followed the posts.   the all pretty much said the check the things i checked.  I tried the uno on an old vista laptop and it would not upload on there either.

did i miss something or is the board defective

please help

Pfroment

I installed ide 1.0.6 on my vista lap top..IT WORKED.   but i still cant figure why it wont upload on my win 10 lap top.   i have done extensive research and tried every thing but still get avrdude: ser_open(): can't set com-state for "\\.\COM on my uno ver3

ballscrewbob

@Pfroment

TOPIC MERGED.

Could you take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google (who would have thunk it ! ) or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

DrAzzy

Error indicates bad drivers

Is this a clone uno with a different serial interface chip? (Official boards use an 16u2 running firmware that makes it into a usb serial adapte; clones usually use ch340g, sometimes cp210x ). Check markings on black chip near usb port on arduino.

Drivers for clones are not installed with the ide - just Google your os version, part number of serial adapter chip, and the word "drivers "
ATTinyCore and megaTinyCore for all ATtiny, DxCore for DA/DB-series! github.com/SpenceKonde
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

Go Up