Go Down

Topic: Cant upload any project (version 1.8.10) (Read 569 times) previous topic - next topic

vlad5000

Hello, I have problems with uploading any project, every project I make it says Error compiling to board Arduino/genuino     exit status 1     multiple libraries were found. I only have one library of each type, is there any way I can fix this and not downloading any older versions of Arduino???

pert

Please do this:
  • When you encounter an error, you'll see a button on the right side of the orange bar "Copy error messages" in the Arduino IDE (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button..
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum's code tags markup to your reply.
  • Press "Ctrl + V". This will paste the error between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.


If the text exceeds the forum's 9000 character limit, save it to a .txt file and post it as an attachment. If you click the "Reply" button here, you will see an "Attachments and other settings" link.

vlad5000

Code: [Select]
Arduino: 1.8.10 (Windows 10), Board: "Arduino/Genuino Uno"

cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin.

cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin.

cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin.

cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin.

cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin.

Multiple libraries were found for "LiquidCrystal.h"
 Used: C:\Program
Multiple libraries were found for "Keypad.h"
 Used: C:\Users\valariey\Documents\Arduino\libraries\Keypad
exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.




it says multiple libraries were found with any library I add in any of my projects

pert

Please do this:
  • (In the Arduino IDE) click File > Preferences
  • Check the box next to "Show verbose output during: > compilation
  • Click "OK"
  • Sketch > Verify/Compile
  • After the compilation fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum's code tags markup to your reply.
  • Press "Ctrl + V". This will paste the compilation output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.


If the length of the output exceeds the forum's 9000 character limit, save it in a .txt file and post it here as an attachment. If you click the "Reply" button you'll see the "Attachments and other options" link.




it says multiple libraries were found with any library I add in any of my projects
The "Multiple libraries found for" message has nothing to do with your problem. That's just some helpful information the Arduino IDE provides. Generally, you can safely ignore the "Multiple libraries found for" messages. The only time you need to pay attention to it is when the Arduino IDE picked a different library than the one you had intended.

Note that there is a bug in Arduino IDE 1.8.10 that causes it to display "Multiple libraries found for" messages even when there were no multiple libraries. You'll know the legitimate "Multiple libraries found for" messages because they'll show the path to a library that was not used. The false "Multiple libraries found for" messages only show the path to the library that was used.

vlad5000

I posted a text file

pert

Try this:
  • Tools > Board > Boards Manager
  • Wait for the downloads to finish.
  • Click on "Arduino AVR Boards".
  • Click the "Update" button.
  • Wait for the update to finish.
  • Click the "Close" button.
  • Try uploading your sketch again.


Hopefully the update will fix the problem. If not, let me know and I'll provide some instructions for an alternate fix.

vlad5000

 :)  :)  :) Thank you, finally I got it to compile I hope this won't happen again. :)  :)  :)  :)  :)

pert

You're welcome. I'm glad to hear it's working now. I don't think it will happen again now that you've updated Arduino AVR Boards. If it does, we're always available here on the forum to help you out.
Enjoy!
Per

vlad5000

it think i got problems again now before I could compile it but now the problem is I can't upload it
is the problem with my schematic or code? I left the code on the attachment.

vlad5000

I think it could be a problem with the schematics because my LCD is blinking rapidly

pert

No, it's not a problem with schematics. It's the same error as before:
Code: [Select]
cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin.

This is caused by some issue with the Arduino IDE or Arduino AVR Boards installation.

It's very strange because I can see that Arduino AVR Boards 1.8.1 is being used, but that shouldn't be because you updated to Arduino AVR Boards 1.8.2 by following the instructions I gave in the previous reply.

Please do this:
  • Tools > Board > Boards Manager
  • Wait for the download to finish.
  • Under "Arduino AVR Boards", it will say which version of Arduino AVR Boards is installed. What does it say?

vlad5000

It says i have the 1.8.2 version but below that, it says Boards included in this package: Arduino Yun
Arduino Uno, Arduino Uno wifi, Arduino Diecemila, and then other boards

vlad5000

It says i have the 1.8.2 version of the AVR boards

vlad5000

I started another project maybe that code I made was a bad code but I still get the error code I left a text file

pert

OK, now it's using Arduino AVR Boards 1.8.2 as expected. The error you posted has a completely different cause:
Code: [Select]
C:\Users\valariey\Documents\Arduino\libraries\DHT_sensor_library\DHT_U.h:36:10: fatal error: Adafruit_Sensor.h: No such file or directory

 #include <Adafruit_Sensor.h>

          ^~~~~~~~~~~~~~~~~~~



When you see a "No such file or directory" error it almost always means you need to install the library that contains the missing file.

Often the code you're compiling will come with documentation (either a comment or separate document) that tells you where to get the library dependencies.

In other cases the author of the code will not have been so kind and you'll need to go on a hunt for the missing library.

A good place to start is the Arduino IDE's Library Manager:
  • Sketch > Include Library > Manage Libraries...
  • In the "Filter your search..." box, type some keywords you have gleaned from the missing file name.
  • Scroll through the results for the right library. Click on it.
  • Click "Install".
  • Wait for installation to finish.
  • Click "Close".
  • Try compiling your code again.


If you have no luck in Library Manager then load up your favorite search engine and do a search for the missing filename. You will often get multiple results. If you have a lot of results you might add "arduino" as an additional search keyword. I will usually prefer results on github.com since that is where most Arduino libraries are hosted and downloading from there is fast and easy. In some cases there will be multiple libraries that contain the given filename and you'll need to do some evaluation to determine which seems the most appropriate, then try it out. After downloading the library you found you'll need to install it. This requires a different process than the Library Manager installation. You will find instructions here:

Go Up