Go Down

Topic: Arduino IDE Not Fully Install & Does Not Launch (Read 354 times) previous topic - next topic

jasona77

I am trying to install the IDE on Kubuntu 19.10 and I get the following error:

Code: [Select]
touch: cannot touch '/root/.config/mimeapps.list': No such file or directory
/usr/bin/xdg-mime: 848: cannot create /root/.config/mimeapps.list.new: Directory nonexistent


Even though I get the error, I still get the "Done!" message. The icon shows up the Application Launcher but no desktop icon. Also, when I try to launch the IDE from the Application Launcher, nothing happens. The only thing I tried was to change RESOURCE_NAME=cc.arduino.arduinoide to RESOURCE_NAME=arduino-arduinoide as suggested in another thread. That did not work. Not quite sure what to do in order to fix this and was wondering if someone on this forum did know. Thanks in advance.

sterretje

#1
Jan 13, 2020, 07:33 pm Last Edit: Jan 13, 2020, 07:33 pm by sterretje
You have no business in /root ;)

Did you download the IDE from the KUbuntu repo or from the Arduino website?

I don't think that I can help much further (Linux user long ago).
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

pert

I see there is an outstanding bug report about it in the issue tracker:
https://github.com/arduino/Arduino/issues/7846
That stalled because the person who reported the issue never bothered to submit the information the developer requested. You might be able to get things moving on it by doing what cmaglie requested and posting the output in that issue thread.

Other than that, I suspect that the Arduino IDE will start just fine if you run the arduino script you find in the folder where you extracted the IDE download file. I never bother with that installation script.

jasona77

I just ran the uninstall script and just use the arduino file as suggested. Now it works great! I even created a desktop shortcut. Thank you everyone for your help.

pert

I'm glad to hear it's working for you now. Enjoy!

Go Up