Go Down

Topic: Problema con LCD URGENTE // LCD Urgent Problem (Read 2461 times) previous topic - next topic

joselillo51

Apr 30, 2016, 03:17 pm Last Edit: Apr 30, 2016, 03:26 pm by joselillo51
Tengo un problema con la pantalla lcd.

He retomado un proyecto antiguo y me he encontrado un problema con la pantalla LCD.

La pantalla solo imprime el primer caracter de la frase.
He probado a cambiar la librería a probar con otra LCD, pero sigue sin funcionar.

Necesito ayuda, no se que probar.

Gracias y espero que me ayudeis.

...

I have a problem with the LCD screen.

I have taken up an old project and I found a problem with the LCD screen.

The screen only prints the first character of the sentence.
I tried to change the library to try another LCD , but still does not work .

I need help , you can not prove.

Thanks and hope for help me .

TommiP

#1
Apr 30, 2016, 04:38 pm Last Edit: Apr 30, 2016, 04:44 pm by TommiP
Without seeing your code it's quite hard to try solve your problem. You might find result from there..

http://forum.arduino.cc/index.php?topic=361637.0

Topic search usually helps, you are not alone  :)

TommiP

joselillo51

Thanks for the link , I've been watching and I have come to understand that it is a incopatibilidad of the library with the IDE version . I will desistalar my Version 1.6 and I will install 1.0

now I tell you. Thank you very much for the attention you have devoted to me.

joselillo51


It is indeed a problem of incompatibility of the library and IDE version .

Anyone know how to resolve this inconsistency ?

TommiP

#4
Apr 30, 2016, 05:43 pm Last Edit: Apr 30, 2016, 05:49 pm by TommiP
In can't solve the issue itself but I know how to go around.. :)

I'm using 1.6.5 with these libraries and everything work like they suppose to..

Code: [Select]

#include <Wire.h>
#include <LiquidCrystal_I2C.h>

// Set the LCD address to 0x27 for a 20 chars and 4 line display
LiquidCrystal_I2C lcd(0x27, 20, 4);

void setup()
{
lcd.begin();

lcd.print("Hello, world!");
}

void loop()
{
// Do nothing here...
}



If you have multiple wire-libraries on your computer, dispose them and leave only one in the folder \Arduino\hardware\arduino\avr\libraries

TommiP

joselillo51

1.6.5 versión correcta si funciona bien.

La versión 1.6.8 es la que tiene el fallo. Es un poco extraño, pero he cambiado de version y funcionó.

floresta

Although Reply #1 has a link to an early thread about this problem a lengthy explanation was added more recently.

Another early thread with a solution (also by bbperrybap) is here: --> http://forum.arduino.cc/index.php?topic=361411.msg2491934#msg2491934

Don

bperrybap

The fix for this is quite simple. See the thread that Don pointed to above.

There is a LiquidCrystal_I2C library available through the IDE library manager.
If you are using this library, which had this issue, it was fixed in late 2015.
(Note: There are multiple LiquidCrystal_I2C libraries that are different but all have the same name)

The issue was that the git repository was not properly tagged to make the fix for this library available through the library manager until very recently.
If you are using that LiquidCrystal_I2C library, then you could update your library with a newer version through the library manager.

--- bill

SAQLAIN62

i using ardiuno uno 16*2 lcd display uploading program hello world with i2c  but not show display and  iDE version 1.8.10 reinstall 2 time master i2c library install   
please solution   

Paul__B

#9
Jan 25, 2020, 10:08 am Last Edit: Jan 25, 2020, 10:09 am by Paul__B
Read the instructions then, and explain your problem.

Go Up