Go Down

Topic: Arduino Web Editor - WeMos ESP8266 D1 mini - Nano 33 IoT download problem (Read 492 times) previous topic - next topic

ianhindle

Hi,

I have just upgraded my account to "Maker Plan" which opens up the opportunity to produce and download sketches to the full range of Arduino supported boards via the online Arduino Web Editor.

As you'd expect, I'm working from a Chromebook, in fact a Google Pixelbook.  However, I'm finding it impossible to download sketches to both Nano 33 IoT or WeMos ESP8266 D1 mini devices. Downloads to other Arduino boards are fine, i.e. Nano, MKR1010, etc.

Having looked through the forums I can't see if anyone else is having a similar problem.

Hence this post to see anyone has experienced the issue and if there a fix which I've missed.

Regards
Ian

pert

I don't own a ChromeOS device so I can't try it out using the Arduino Create Chrome App, but I did just try uploading to both those boards using Arduino Web Editor and it worked fine for me.

Please do this:
  • Attempt an upload.
  • Wait for the upload to fail.
  • Hover the mouse over the red bar at the bottom of the Arduino Web Editor that shows the error message. Click and drag it up so you can see the black console window.
  • Click the icon in the top right corner of the console that looks like two pieces of paper.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum's code tags markup to your reply.
  • Press "Ctrl + V". This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

If the length of the output exceeds the forum's 9000 character limit, save it in a .txt file and post it here as an attachment. If you click the "Reply" button you'll see the "Attachments and other options" link, which will allow you to make the attachment.

ianhindle

Firstly, thanks for your help and sorry for taking so long to reply. I've been taken back a little by my own findings. Having struggled to get either the NANO 33 IoT or the WeMos ESP8266 Mini D1 to compile and download, I've just tried to reply to your help and all of a sudden the NANO 33 IoT is working. Very strange.

Positive, or not the WeMos device will still not work. Following your instructions I've tried to compile the example Blink sketch and download it to the WeMos device. Included is the output error messages.

The message in the red bar is "Unsupported Board!"

Code: [Select]
/home/builder/opt/arduino-builder/arduino-builder -compile -core-api-version 10611 -hardware /home/builder/opt/arduino-builder/hardware -hardware /home/builder/.arduino15/packages -tools /home/builder/opt/arduino-builder/tools -tools /home/builder/.arduino15/packages -built-in-libraries /home/builder/opt/libraries/latest -logger humantags -fqbn esp8266:esp8266:d1:baud=921600,dbg=Disabled,eesz=4M,exception=disabled,ip=lm2f,lvl=None____,vt=flash,wipe=none,xtal=80 -build-cache /tmp -build-path /tmp/798283109/build -verbose -prefs runtime.tools.avrdude.path=/home/builder/.arduino15/packages/arduino/tools/avrdude/6.3.0-arduino8 -prefs runtime.tools.arm-linux-gcc.path=/home/builder/.arduino15/packages/arduino/tools/arm-linux-gcc/4.9.3 -prefs runtime.tools.arduinoOTA.path=/home/builder/.arduino15/packages/arduino/tools/arduinoOTA/1.3.0 -prefs runtime.tools.x86-linux-gcc.path=/home/builder/.arduino15/packages/arduino/tools/x86-linux-gcc/7.2.0 -prefs runtime.tools.arm-none-eabi-gcc.path=/home/builder/.arduino15/packages/arduino/tools/arm-none-eabi-gcc/7-2017q4 -prefs runtime.tools.sketchUploader.path=/home/builder/.arduino15/packages/Intel/tools/sketchUploader/1.6.2+1.0 -prefs runtime.tools.arc-elf32.path=/home/builder/.arduino15/packages/Intel/tools/arc-elf32/1.6.9+1.0.1 -prefs runtime.tools.avr-gcc.path=/home/builder/.arduino15/packages/arduino/tools/avr-gcc/7.3.0-atmel3.6.1-arduino5 -prefs runtime.tools.flashpack.path=/home/builder/.arduino15/packages/Intel/tools/flashpack/2.0.0 -prefs runtime.tools.CMSIS-Atmel.path=/home/builder/.arduino15/packages/arduino/tools/CMSIS-Atmel/1.2.0 -prefs runtime.tools.nrf5x-cl-tools.path=/home/builder/.arduino15/packages/arduino/tools/nrf5x-cl-tools/9.3.1 -prefs runtime.tools.CMSIS.path=/home/builder/.arduino15/packages/arduino/tools/CMSIS/4.5.0 -prefs runtime.tools.mkspiffs.path=/home/builder/.arduino15/packages/esp8266/tools/mkspiffs/2.5.0-3-20ed2b9 -prefs runtime.tools.openocd.path=/home/builder/.arduino15/packages/arduino/tools/openocd/0.10.0-arduino9 -prefs runtime.tools.core2-32-poky-linux.path=/home/builder/.arduino15/packages/Intel/tools/core2-32-poky-linux/1.6.2+1.0 -prefs runtime.tools.i586-poky-linux-uclibc.path=/home/builder/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0 -prefs runtime.tools.arduino101load.path=/home/builder/.arduino15/packages/Intel/tools/arduino101load/2.0.1 -prefs runtime.tools.dfu-util.path=/home/builder/.arduino15/packages/arduino/tools/dfu-util/0.9.0-arduino1 -prefs runtime.tools.linuxuploader.path=/home/builder/.arduino15/packages/arduino/tools/linuxuploader/1.5.1 -prefs runtime.tools.esptool.path=/home/builder/.arduino15/packages/esp8266/tools/esptool/2.5.0-3-20ed2b9 -prefs runtime.tools.xtensa-lx106-elf-gcc.path=/home/builder/.arduino15/packages/esp8266/tools/xtensa-lx106-elf-gcc/2.5.0-3-20ed2b9 -prefs runtime.tools.bossac.path=/home/builder/.arduino15/packages/arduino/tools/bossac/1.9.1-arduino1 -libraries /tmp/798283109/custom -libraries /tmp/798283109/pinned /tmp/798283109/Blink_copy

Sketch uses 258580 bytes (24%) of program storage space. Maximum is 1044464 bytes.

Global variables use 26696 bytes (32%) of dynamic memory, leaving 55224 bytes for local variables. Maximum is 81920 bytes.

Validating license ...

pert

From https://store.arduino.cc/digital/create:
Quote
3rd Party Boards support on Web Editor
Possibility to verify and upload to additional boards like the ESP8266 boards. Available only using Arduino Create Agent, not available using the Chromeapp.
So you can't use the ESP8266 with the Arduino Create Chrome app.

Go Up