Go Down

Topic: Setting preferences save (Read 430 times) previous topic - next topic

hextejas

This is kind of an odd problem.
When I try to change some of the preference settings, the size of the popup window is so large that the ok/apply/save button is below the bottom edge of the screen and I can't push it.
I tried repositioning the task bar but that didn't help.

Any ideas ?

Thanks.

pert

Which version of the Arduino IDE are you using? Some recent efforts have been made to make the preferences dialog work with low resolution screens.

You also have the option of editing the preferences file directly:
You can find the location of the file at the line following File > Preferences > More preferences can be edited directly in the file.

If you can't see that line of the Preferences dialog, the locations of the file are:

On Mac OS X:
/Users/{username}/Library/Arduino15

On Windows:
Arduino IDE 1.6.5r5 and previous:
C:\Users\{username}\AppData\Roaming\Arduino15
Arduino IDE 1.6.6 and later:
C:\Users\{username}\AppData\Local\Arduino15

Using Windows App Store version of the IDE:
C:\Users\{username}\Documents\ArduinoData

On Linux:
/home/{username}/.arduino15 (a.k.a. ~/.arduino15)

The file is named preferences.txt.

Close the Arduino IDE before editing preferences.txt.

There are some additional preferences in preferences.txt that you can't access via the Arduino IDE.

You can open it in a text editor, make whatever changes you need, save it, then start the Arduino IDE and the preferences changes will be in effect.

If you need help setting specific preferences, let me know and I'll provide instructions.

hextejas

Thank you pert.
One of the parameters that I changed in the .txt file was the "verbose output during compilation".
I need it sometimes when I am debugging.
And to that end let me explain another situation.
The sketch was written by another and I have been trying to make it work.
I got it working on my main PC, a Manjaro linux box running Arduino 1.8.5.

I copied the complete folder structure \home\arduino-1-8-5\*.* to a smaller, Acer Aspire notebook.
The compile now gives me errors and I think that it has to do with using different libraries.
As an example the library that the IDE uses on the Acer is:
/root/.Arduino15/packages/esp8266/.....

and on the Manjaro PC is:
/home/hexdump/Arduino-1.8.5/hardware/esp8266com/esp8266/libraries/ESP8266WiFi
etc.


Is there a way in the preferences that I can tell the compiler the path to the libraries ?
Most of the libraries are at version 1.0 with a few exceptions.

I could try copying the PC libraries over the Acer libraries but I am reluctant to do that.
Is there another way to get the libraries in sync ?

This is an expansion of my original thread so do you want me to start a new one ?

hextejas

Actually let me read your post about the use of the #include and " or <>

hextejas

I am running on an Acer Aspire notebook and the buttons are on the bottom.
If I try and change the preferences, I cannot push the save button because it is hidden behind the task bar buttons.
Is there a way that I can make the popup shorter ? I know that within the preferences I can make the main IDE window smaller, well how about the preferences popup ?

thanks

hextejas

Consider this fixed.
Arduino 1-8-12 fixed it.

thanks folks.

Go Up