Go Down

Topic: LilyGo Atmega32u4 clear bootloader (Read 173 times) previous topic - next topic

rubatu

Feb 16, 2020, 07:00 pm Last Edit: Feb 16, 2020, 07:01 pm by rubatu
Hello my problem to find a solution which I could not.

There is such a device:


Inside it is Atmega32u4. I tested a virtual keyboard on Windows 10, everything worked as it should. I tried to insert LilyGO into another Windows 7 PC; there was a search for drivers that never came. I started looking for how to solve the problem, they advised me to remove Bootloader so that the sketch would start right away. I did this with the following method:

1. In Arduino IDE clicked Sketch-> Export binary

2. Through the program 32u4_hexUploader uploaded HEX which without bootloader

I tried the sketch, everything works fine. On Windows 7, it still writes the device was not found, but it works.

 
But now the problem is, I can't upload a new sketch. I tried to fill in through 32u4_hexUploader HEX which with the bootloader but the program hangs. I tried through avrdude also freezes.

Tell me what can be done? Regarding arduino, I'm just a beginner, I understand. Only this device is available and I don't want to disassemble it. Can I do something ?? I really need your help!

P.S. Sorry for my Eng

ieee488

Without the bootloader, you cannot upload anything anymore.

My guess you would need to take apart the LilyGo and program the 32u4 with something like this https://www.xeltek.com/resources/technical-articles/ic-manufacturers/atmel-avr-programmers/

Go Up