Go Down

Topic: Bare Bones Board won't respond (Read 1 time) previous topic - next topic


I have a bare bones board and a usb bub (usb to ttl converter, pretty much just a max232). It no longer responds when I try to program it. I get an stk500: programmer not responding error when I try to program it. I can program my other arduinos and teensys just fine, but not this one. I tried arduino as ISP to reburn the bootloader, but I get a not in sync error. I tried both in circuit (in the bare bones board), and just on a circuit board (no oscillator, so it shouldn't run at all, my goal was to program it to use the 8MHz internal, then after that try to get it to cooperate with the 16MHz external). It's an atmega328 on the bare bones board. I also swapped the chip with the one on my duemilanove, and couldn't program it there either (but could program the duemilanove 328 in the bare bones board), so it's definitely the chip. I messed with programming at 3v3 and 5v on the BUB, neither works. Any ideas to try to fix it? I have a willem parallel programmer (it has ISP, but no mosi :( ), I don't think it will help, but it's worth mentioning.

tldr: atmega328 won't respond to any programming efforts, using both serial and arduino as ISP.

I'm using 10.6.7 on a MacBook Air, and arduino 0022.


Hello adcurtin,

I have a willem parallel programmer

Do you mean an eprom programmer ? If it is the case, I don't think it can help you.

If the atmega is still alive, the fuses are probably messed up. You should be able to read the signature and the fuses and then correct them. But you need a programmer to do that.
I use an avrisp mkII programmer, bought as a kit here http://fun4diy.com/AVRISP_mkII.htm
It is working perfectly.
You can also buy an official one or a cheap one from ebay.

Amicalement, Jean-Marie


You say you have a duemilanove?
You could try bit-banging it, taking advantage of the FTDI chip.
You will need to unsolder 4 holes on the duemilanove, add pins there for easy access, then follow the steps to read/reset fuses, burn ew bootloader, etc. if the chip is not dead.

Order a couple spares from Newark.com also, are on sale now even for $3.42, qty 1-9.
I just received 20 DIPs and 10 Flatpacks for future projects, $2.93 each for 10+.

Prices have dropped, used to be like $5.50 per chip.
Mouser down to $3.93
Still $4.98 at Digikey.


Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.


I've got a standalone FTDI board as well.  I can swap the broken Atmega with the one in the duemilanove, if that would mean I didn't have to unsolder anything on it. I'll look at the read and reset fuses procedure (if I can find it), and report back if that works.


well I fixed it. I reflashed the BBB's boatloader. When I tried before, the problem was that the duemilanove was auto-resetting. A 120ohm equivalent resistor (3x100 + 2x 150 in parallel to get about 22 ohms, plus a low 100ohm [98.2ish] in series to get about 120.3 ohms) between 5v (I think, check the MegaISP page) and reset solved that.
Then I was able to reflash the bootloader on the BBB, and flash a bootloader on the bare 328p I ordered to replace it.


How'd you reflash it? I am not having any luck getting a boot loader into a 328 that will then accept sketches.
Sounds liky just pulled reset up high.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

Go Up