Go Down

Topic: UNO and USB (Read 1 time) previous topic - next topic


This is my second UNO.  Each was purchased from a different dealer.  After using the 1st UNO for about a week, it began to loose the USB.  The USB was not recognized by 2 computer systems using 4 different cables.  I reloaded version 0022 with no good results.  I tried to reload the8u2 but flop could not find the device.  I then decided that i had somehow fried the USB.  I purchased a second unit and afetre about a week, it failed the same as the first.

I am beginnig to believe that the problem is not entirely by my own fault.  It may be in the hardware or in the instructions.  Sure wish that someone had an answer for this problem.

Using the UNO on a windows 7 and Vista systems.  


I purchased a second unit and afetre about a week, it failed the same as the first.

Are you wiring anything up to these two arduino boards? If so share your wiring diagram with us to see if you could be the cause of the failures.



My being the problem is a real possibility.  Basically I considered the first unit to be a normal USB device with hot swap capability.  I would disconnect the usb cable indiscriminately.  I was trying to get the Rugged stepper motor driver demo software working with this unit.  Nothing happened and I would change the wiring order to see if there was any movrmnt.  Never saw anything.  The stepper motor is a Hurst LSG42012F76P unit.  Since the motor has Bifilar windings I have some allowable variation in the connections. 

At first I would use the Arduino UNO power jack (to the right of the usb port) but there was nor motor movement an d I then changed the 112V power input to the Rugged controller and reloaded the software and tried again.  Still no movement.  Finally I wired the 12V positive lead directly to the motor. The ground was maintained through  a wire from the motor housing to the ground point on the power of the rugged controller power strip.  Ground was maintained through the standoff connection to the UNO AND back through the UNO usb.  These actions took a few days.  Most of the time was spent trying to find and digest additional info on the Arduino-Rugged hardware abd software interfaces.    It should be noted that there were many connects and disconnects during these trials.  Some were due to software and othees to allow me to change the order of wiring to the Rugged coil posts.  I would shut the systems down every night and reboot the next day.  When I connected to the Arduino I would check the Device manager and note the Cpm port assigned to the unit.  It was always Com 5 until the day when it quit showing up.  After more searching I found Flip (v3.4.3) and found some firmware for the 8U2 chip.  However when I would try to get Flip to finde the Arduino it couldn't.  The Arduino power LED was lit but nothing else.  At this point I decided that I had fried the UNO USB chip.and purchased another from Adafriuit along with their Motor driver.  Lo and behold the same thing happened as with the first unit.  No motor movement with the test/demo software.  My hot swapping was really curtailed.  If i was changing wiring I would disconnect the 12 V connected to the controller board first and then disconnect the USB cable from the UNO.  I was thinking that disconnecting the USB from the UNO first may have caused some spikes in the UNO since the ground was passing through the UNO usb system.  Apparently this made no difference since, after almost the same amount of time, this unit failed the same way as the first.  I also tried to connect the motor as specified by the manufacturer (12V applied to the motor coils and the ground switched on and off.  the other way was the opposite.  The two common leads wre passed to ground and the motor shield Either Rugged or AF Motor would apply PWM'ed power to the coils. Finally there was a referene about using a Bipolar driver with a Unipolar motor by  just letting the common power/ground leads hang loose and drive the coils from the driver shield. There has been one error dialog showing up sporadically on the second board.  Basically windows sees something and thinks it belongs in the Human interface area of device manager.  It is listed as an unknown device.  The only result of trying to expnd on the ubknown device is a dialog stating that my device is probably defectiv. 

I have a feeling that the problem is centered around the USB and my treating it as I would any other USB device.   I am getting the impression that the UNO USB is not a true USB, but rather, a a converter ffrom RS2232 to USB.  This could mean that the hot swapping allowed in USM would no necessarily be allowed with the UNO.  If that is the case I am in for a long ordeal using the UNO to controll the stepper driver since none of the test/demo software has worked after making the changes needed to reflect the step size, number of steps  and RPM. 

Thanks for your response.  Since I wrote the frst note I have been thinking about the problem a lot.  Much of the problem is probably my  not understanding the marketing terms used by the manufacturers or retailers.  Another is selecting the correct search terms to find needed data when things don't go right.  I still haven't found anything on the Net specifically stating not to hot swap the Arduino. 


Not sure I can help in anyway specific, as the complexity you are working with doesn't lend itself to troubleshooting via web postings. I've used arduino for a couple of years now and have had no problems 'hot swapping' them on to and out of the PC. I don't own a UNO so my arduino boards use the FTDI brand USB serial converter chip rather then the 8u2 chip that the Uno uses, but I don't think there is any restrictions on how and when you may plug it into a PC. The only electrical connections between the 8u2 usb chip and the 328p processor chip is ground, +5vdc power and serial data via pins 0 and 1. Of course with your USB function out to lunch you have no way of knowing if the failure mode cause your 328p damage also or not.

There can be electrical problems if you unplug power to the Uno board but there are still 'hot' signals coming from any external components or modules, this can cause 'backwards' current flow through I/O pins that can cause damage in some cases. Again hard to diagnose anything without all the schematics and inter-wiring drawn out.

Good luck on your project, and try and figure out something different to try rather then just replacing the damaged arduino board after the fact.  :D


Are you using a laptop by any chance to connect to the Arduino?

Laptops run from a (mostly) isolated switchmode supply, and can present a weak ~90-100V on the USB connector shell, effectively floating above the unit about to be connected, and then inject a zap into any USB device that is powered from another ground or mains ground before the connection.

It may be that your stepper driver/board supply ground and the PC ground have a voltage difference between them and it's zapping your board's USB IC a bit when connected.
This can happen with a regular desktop PC also depending on where the device's supply ground is coming from. As soon as you mentioned stepper motor on the board side I thought of this possible issue.

You can measure with a multimeter on both DC and AC, between the PC cable USB shell and the board USB shell and GND before connection, you may find a damaging voltage there. It can be fixed by changing your power sources around to either a common ground, or connect the PC USB/connector shell to the board ground with a wire or similar first, then plug in the USB cable after.

Hope this helps!


thanks for the info.  Retrolefty's summary of the USB used on the older boards gives me some comfort.  Mostly I was thinking I was loosing my mind for a while there.  Your summary makes it easier to plan how to determine a solution.  Marc you really woke me up .  The info about laptops was extremely interesting since the final use of the project will be driven by a laptop (automatic telescope focuser).  I'm using whichever dektop isn't being used for the testing and software modifications/debugging.  Tomorrow I will put a couple of meters on the USB ports and the motor to driver/controller system.  Your comments have started me to look at my laptop too.  Will have to figure out an easy way to to determine if I am having Laptop power problems when I am operating under power conditions that are less than good.  Thanks to the board for my wakeup



I'm sorry to say that I seemed to be wrong about my thinking that the probabiity that the UNO USB port was being wiped out by stray current flows through the USB.  I placed my trusty digital meter on the computer and Arduino grounds and fount 60mV between the computer case and the Arduino ground.  If I go between the computer USB metal casing and the Arduino USB metal connector I get 40mV.  One thing was interesting to me.  These number were the same with or without the Rugged Circuits and Adafruit shields installed.  By the way, I made the measurements 3 times and the variations were less thn 4mV from measurement to measurement.  During each the values were consistand throught the 30-45 seconds I required. 

I was hoping that I could solve this problem .  Without knowing what is causing the problem when I use the Arduino card I will have to start looking elsewhere for a microcontroller.  Anybody have any ideas?

Go Up