Go Down

Topic: Cannot upload: programmer is not responding (Read 3856 times) previous topic - next topic

Coding Badly

The problem is that there are several bootloaders available.  If the vendor really did build a "Freeduino" then, as far as I can tell, "Arduino Duemilanove / ATmega168" is the correct choice and these two settings are correct...

         Using Programmer      : stk500v1
         Overriding Baud Rate  : 19200

However, if the vendor decided to use a different bootloader, then either or both of those settings are wrong.  I cannot find anything on that webpage about bootloader or board selection.  I suggest asking the vendor to confirm that "Arduino Duemilanove / ATmega168" is the correct choice.


According to the accompanying book, you should select "Arduino Diecimila". And the screenshot there selects the entry that ends with "ATmega168", so it seems to be the correct setting.


Just to bring this story to an end: I sent the starter pack back and bought a Sparkfun Inventor's Kit instead -- and that didn't work either, same error. Weird!

I tested it on my wife's iMac, and connected it on its passive USB hub, it worked! So, I tried the free USB port of the Apple keyboard on my iMac, and lo and behold, it worked! (I tried a USB port at the back of the iMac with my first kit, which didn't work. Never thought of the keyboard port until recently...)

It still will not work on the active Belkin USB hub (although there's nothing wrong with it, I use it with USB sticks and my video cam just fine), but as long as it'll work with the keyboard's port, it'll do. (Although I'd prefer it working on a hub, if anything goes awry, the hub would be cheaper than the keyboard...)

If anything has any idea as to why the active hub isn't working, please let me know it I can test anything.

Coding Badly

Go Up