Go Down

Topic: Attiny2313 Clock (Read 1 time) previous topic - next topic

baum

I am using the arduino-tiny cores to program and Attiny2313. The internal 1Mhz setting works fine (I am testing using the blink example), however the 8Mhz clock is not: When this option is selected, the attiny runs 8x slower than it should, the 1 sec blink delay on the above mentioned example becomes 8 seconds. I checked boards.txt and did not find any errors, F_CPU was correctly 8000000L, and I checked all the fuses: they are correct.

Has anybody else had this problem? Any ideas?

Thanks!
baum

madworm

Did you check the fuse settings in the boards.txt file or also on the chip?

CKDIV8 fuse in particular.

baum

I got it to work... I just had to burn the bootloader.

baum

Go Up