Go Down

Topic: how do i reinstall the ethernet library? (Read 979 times) previous topic - next topic

gaggenau

my problem is that no example sketches works with my duemillanove with atmega 328 and a wiznet ethernet shield.
they used to do so before but now they dont and i think it´s because i might have messed up the ethernet library.
I´m using OSX by the way.

to see if reinstalling the ethernet library might solve my problems i have tried to search the internet to se where to download it. but i found nothing. so does anyone know where i can download the ethernet library?


robtillaart


option 1. Reinstall IDE altogether

option 2. download the IDE, search the zip file and copy the ethernet library from the zip to the current ethernet lib location

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

gaggenau

well  Thought of nr 2 that but the arduino IDE for osx does just include 3 files . the arduino execute file, a shortcut to applications folder and the install file for the ftdi drivers.

im going to try do download the windows version of arduino IDE and take library from there.

and i tried replacing my old arduino ide 0022 with a new one but im not shure how the install affects the library folder because all my "third part" libraries is still untouched.

gaggenau

ok thanks for the advice on replacing the library,
but replacing the library did not work so i have to try something else does anyone have a clue.

the sketch compiles and everything looks good on the ethernet shield all status leds that should be lit are lit and the rx and tx leds are flashing sometimes.


But i can´t ping my device so it does not have connection to the network.

robtillaart


Do you have running arduinos in your network?
I was thinking it might be a MAC address conflict....
Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

gaggenau

nope.
tried to connect it directly to the computer instead of using the router.
tried a another ethernet shield. but i did not work either.
tried a another duemillnove also with the same result.

robtillaart

Quote
and i tried replacing my old arduino ide 0022 with a new one but im not shure how the install affects the library folder because all my "third part" libraries is still untouched.


3rd party libraries are better located in a libraries folder in your sketchbook - path can be found from IDE-> FIle_>preferences  -
Than an upgrade of IDE will never damage your libs.

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Go Up