Go Down

Topic: Fonctionnement relais GI-1A-5DH avec Nodemcu v3 (Read 641 times) previous topic - next topic

geangean

Bonsoir,
J'ai l'intention de piloter un relais GI-1A-5DH via le wifi et jeedom notamment. J'ai tout d'abord essayé le montage de RitonDuino (http://riton-duino.blogspot.com/2018/08/alimenter-un-relais-transistor.html) avec un arduino et ça marche très bien (solution mosfet N etc).

Quand je passe sur le Nodemcu le relais ne s'enclenche pas : j'ai pensé que c'était le 3v qui ne convenait pas mais l'arduino est capable de piloter le relais en 3V. Est-ce une question de courant ?
J'ai aussi tenté de brancher une source extérieur de 5V sur le Vin du Nodemcu sans succès.

Après quelques lectures sur le forum, je ne trouve pas mon erreur et demande votre aide.

Merci d'avance.
Julien

hbachetti

Sans schéma ... difficile de dire quoi que ce soit.
Linux is like a wigwam: no Windows, no Gates, and an Apache inside ...

geangean


hbachetti

Il n'y a aucune raison pour que la bobine d'un relais 5V puisse être alimentée en 3.3V.

Comme dit dans la datasheet du relais : 3.75V minimum

Quote
l'arduino est capable de piloter le relais en 3V
Tu fais certainement erreur. Que la commande puisse se faire en 3V grâce au transistor ne fait aucun doute, mais la bobine doit être alimentée en 5V.
Linux is like a wigwam: no Windows, no Gates, and an Apache inside ...

geangean

Bonsoir,
D'accord merci. Comment je peux modifier mon montage dans le bon sens ?

j'ai essayé d'apporter du 5V sur la borne supérieure du relais, mais ça ne marche pas. je ne dois pas comprendre le montage : Si le transistor est passant j'ai bien 5V aux bornes de la bobine non ?

J'utilise un mosfet de kit débutant, IRF520.

Ou alors ce transistor ne convient pas / n'est pas passant avec 3V ?

Merci pour les éclaircissements.
Julien


al1fch

#5
Jun 17, 2020, 10:21 pm Last Edit: Jun 17, 2020, 10:24 pm by al1fch
Quote
Ou alors ce transistor ne convient pas / n'est pas passant avec 3V ?
en effet , avec 3V appliqués entre grille et soure le courant dans le drain reste très faible (environ 250µA)

extrait de cette doc : https://www.vishay.com/docs/91017/91017.pdf


geangean

Une solution avec le nodemcu ? ou faut que je change mon fusil d'épaule, un autre transistor ?

hbachetti

#7
Jun 18, 2020, 01:02 am Last Edit: Jun 18, 2020, 09:48 am by hbachetti
Un IRF520 (9 ampères) pour commander un relais ? ? ?
Un simple PN2222 ou un 2N3904 suffirait amplement.
Linux is like a wigwam: no Windows, no Gates, and an Apache inside ...

geangean

Bonjour,
Je crois que je ne comprends pas trop les choix, mosfet ou bipolaire. C'est une question de puissance non, puisque les mosfet sont appelés "transistor de puissance" ?

J'ai pris un bipolaire que j'avais sous la main (C903), ça fonctionne bien merci pour la solution. D'ailleurs le relais colle avec la tension du nodemcu.

Petite question quant on choix du NPN : quelle valeur dois-je regarder, le courant BE ?

Merci

hbachetti

Un 2SC903 peut convenir.

Quote
Je crois que je ne comprends pas trop les choix, mosfet ou bipolaire. C'est une question de puissance non, puisque les mosfet sont appelés "transistor de puissance" ?
Mon article n'est pas assez clair ?
J'y fais quelques comparaisons suffisamment explicites pourtant ?
Les MOSFETs ne sont pas tous de puissance.

Quote
Petite question quant on choix du NPN : quelle valeur dois-je regarder, le courant BE ?
Idem : mon article parle de courant de collecteur, de gain.
Linux is like a wigwam: no Windows, no Gates, and an Apache inside ...

Go Up