Go Down

Topic: [FIXED] Solution inside :Problem when bootloading a Atmega328P-PU whit mega 2560 (Read 1 time) previous topic - next topic

spikee

Hello , i finally soldered my Atmega328P-pu whit all the nessecary componements.
But i get this error :
Code: [Select]
avrdude: stk500_getsync(): not in sync: resp=0x00
When using my Arduino mega 2560 as isp . Please help me out :)

This is how i connected it :


What i did :

1. Upload the ArduinoISP sketch to my Arduino mega 2560
2. Wired up my arduino mega 2560 to my Atmega328P-PU following : http://i52.tinypic.com/se7p0w.jpg
3. Selected Arduino Duemilanova atmega 328 as board
4. Tools -> burm bootloader -> W/ Arduino as ISp
5. get the error in the terminal :  " avrdude: stk500_getsync(): not in sync: resp=0x00 "


I went on google and looked for ppl whit similar problem but i could not find a post that was exactly like me ( not correct search terms ?) .

Thank you.
And sorry for my bad english

retrolefty

Did you remember to defeat the auto-reset on the mega2560 board? This is done with a resistor or cap (of the proper value between reset and +5vdc pins on the mega board. Search for the proper values.

Lefty


retrolefty


Woud turning off dtr also work ?


If you can manage that, but I'm not sure there is a clear method to do that depending on USB serial driver being used, OS being used, etc. Most just add the temporay resistor or cap to suppress the DTR pulse when using the Arduino as ISP sketch.

Lefty

spikee

I Used an 100nF cap between +5v and Reset.
I also made and instructables to help other people http://www.instructables.com/id/How-to-use-Arduino-Mega-2560-as-Arduino-isp/ check it out.

Thank you lefty for helping me !

Gr. Spikee

Go Up