Go Down

Topic: Error: "Selected board depends on 'arduino' core (not installed)." (Read 262 times) previous topic - next topic

roel_ams

Hi,

I normally would not open a topic for these kind of question, as I always manage to solve my issues searching the internet.

However, after two days of trying to fix the issue, i'm stuck.

I was running Arduino IDE 1.8.12 without any issues for months. However, since two days when trying to build a (any) project it fails with the error message "Selected board depends on 'arduino' core (not installed).".

I have searched this forum, and people with the same issue reported this 5 years ago, and managed to solve it.

I'm using the Arrow / Smart Everything Fox board, for which I have installed the board from the Board Manager. Using the already included boards, I don't get this error message. So the problem is between Arduino IDE and the Smart everything board library.


What I have tried:

- Removed everything: Arduino IDE, ~/.arduino15 directory, ~/Arduino directory.
- Installed different versions of Arduino IDE (1.6.*, 1.8.*)
- Installed different versions of Arrow board library
- Installed different versions of Arduino AVR Boards library

Any tips?

Thanks in advance!


ballscrewbob

After having installed so many versions of the IDE a clean up may be worth a shot also.

Attached a method that has worked for lots of people.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google (who would have thunk it ! ) or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

roel_ams

Thanks, for the document. Although I'm running Linux, I will check if I can get any hints from the document.

Tips from Linux users, still welcome :-)

tf68

Do you have the arduino core that supports the processor on your board installed?

pert

The "Arrow Boards" platform has a dependency on the "Arduino SAMD (32-bits ARM Cortex-M0+)
  • Boards" platform. So you also need to install Arduino SAMD Boards:
  • Tools > Board > Boards Manager
  • Wait for the downloads to finish.
  • From the list of platforms, click on "Arduino SAMD (32-bits ARM Cortex-M0+) Boards".
  • Click the "Install" button.
  • Wait for the installation to finish.
  • Click the "Close" button.

You will now be able to use your Smart Everything Fox board without getting that error about the missing core.

roel_ams

The "Arrow Boards" platform has a dependency on the "Arduino SAMD (32-bits ARM Cortex-M0+)
  • Boards" platform. So you also need to install Arduino SAMD Boards:
  • Tools > Board > Boards Manager
  • Wait for the downloads to finish.
  • From the list of platforms, click on "Arduino SAMD (32-bits ARM Cortex-M0+) Boards".
  • Click the "Install" button.
  • Wait for the installation to finish.
  • Click the "Close" button.

You will now be able to use your Smart Everything Fox board without getting that error about the missing core.
Thanks, this was the solution! Everything works again!


Go Up