Go Down

Topic: ATmega2560 board can''t compile the sketch (Read 114 times) previous topic - next topic

tommy602008

Mar 28, 2020, 01:36 pm Last Edit: Mar 28, 2020, 01:56 pm by tommy602008
Hi all,

I have connected the board and chose the right port with the COM. I also selected the board with Arduino Mega 2560.

I am trying to input the program code to IDE software, then bring out the error code as below:

Arduino: 1.8.12 (Windows Store 1.8.33.0) (Windows 10), Board: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Error compiling for board Arduino Mega or Mega 2560.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.



I have found the Board information. Does the board information show the proper board name? Or never properly connected?

BN: Unknown board
VID: 1A86
PID: 7523
SN: Upload any sketch to obtain it


UKHeliBob

Please do not send me PMs asking for help.  Post in the forum then everyone will benefit from seeing the questions and answers.

pert

I have found the Board information. Does the board information show the proper board name? Or never properly connected?

BN: Unknown board
VID: 1A86
PID: 7523
SN: Upload any sketch to obtain it
This is because you are using an Arduino Mega 2560 derivative board with the CH340 USB to serial adapter chip instead of the ATmega16U2 USB to serial adapter chip used on the real Arduino Mega 2560 and faithful clones. It is normal and expected for your board and has absolutely nothing to do with the compilation error you are getting.

Go Up