Go Down

Topic: Arduino board not getting detected (Read 7345 times) previous topic - next topic


I am a newbie to arduino. Trying to build a dust sensor.I am trying to connect an arduino UNO with my PC but does not seem to connect.Checked device manager and the device is not being shown in other devices. Need Help!!

Arduino: 1.8.12 (Windows 7), Board: "Arduino Uno"

Sketch uses 4098 bytes (12%) of program storage space. Maximum is 32256 bytes.
Global variables use 246 bytes (12%) of dynamic memory, leaving 1802 bytes for local variables. Maximum is 2048 bytes.
Serial port not selected.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


Good day
I was wondering if you managed to get the uno board working. I am a newbie at this and i am having difficulty with the uploading. Any info would help.





Same for me. UNO not being detected by the software??


same problem and im new too i see no help maybe i should think about returning


When a board is not "seen" by the Arduino IDE it is usually a system issue.
If the board is correctly detected by the Operating System then its serial port is not being recognised.

Often the main reasons for this are:

- the board is not an original Arduino board (we make sure our boards need no driver to work on Windows, Linux, Mac OS
This means you'll need to identify which drivers to install, but for that we suggest you get in touch with who sold you the board.

- the board is an original Arduino and you have not removed it from the "conductive foam".
That foam is there as an electro-static discharge protection, but should be removed before using the board



I am having the same problem, Arduino Uno, Com9, and I get-
We could not find any board.
Are you sure you have a board connected to your computer with a USB cable? Did you just take your Arduino Board out of the box? Did you remove the conductive foam from the board? Do you see at least an LED ON on your board?
Try checking your cable connection. You can also write us on the Forum.

So here I am, my board is out of foam, yellow light blinking,green light steady, just out of the box, tried two different USB cables and two different USB ports.

Are there any suggestions to help with next steps?


Same problem, card not detected. I have tried on a Mac and a PC, different ports, different USB cables.
I removed the foam before connecting of course, green led on and yellow one is blinking.
I changed the arduino card (MKR Wifi 1010) and the problem is the same.
So this is not the computers, not the cable, nor the card.....
The cloud ?



I have  a related problem. Board is detected, but Alexa can't find my board. I assume it is a bug with the Arduino Alexa skill (by Arduino). But we have to remember that the Arduino cloud is in beta so bugs are to be expected. I have spent a lot of time trying to get it to work. But I will keep my board regardless (Nano 33 IOT). It is not that expensive and I can find other uses for it I am sure. :)

Go Up