Go Down

Topic: No response from Nano 33 IoT when Nano is acting as webserver (Read 653 times) previous topic - next topic

RichBoud

I uploaded the 'WiFi Web Server LED Blink' example sketch. This runs and shows in the serial output that it has connected to my WiFi. However, when I connect my browser to the IP address the sketch gives 'http://WhateverIPAddress/H' nothing happens - eventually the browser times out. Inspecting the Nano code I see that Nano never detects any new client and so no response is ever triggered.

I altered the code to continuously output the network status - this seems to work and the Nano thinks it is still connected to the same IP address.

I have tried the 'Scheduled WiFi SSL Web Client for MKR1000' sketch and this works fine. The Nano acts as a client and downloads the Arduino logo from the Arduino website as expected.

I think the firmware is up to date - I ran the check and it passed.

I have scanned my network for connected devices. The Nano does not appear anywhere in the list and the IP address it gave does not appear to be used.

Any thoughts gratefully received.

Klaus_K

There are two examples that are very similar.

- SimpleWebServerWiFi
- AP_SimpleWebServer

The first one connects to your wifi network and the second one creates a wifi network. Otherwise they are the same.

If you use the first example everything should work as you expect.

If you use the second example, you will have two networks with the same name and password, but your PC/tablet/smartphone will likely only show you the original one and stay connected to it. Your router will not show you the Arduino because it is not connected to the routers network.

What is the exact output you get from your serial monitor? You should not see anything about "access point".

RichBoud

Thank you Klaus.

I think I was using the first example. I have tried downloading it again and still have the same problem.

The serial output is:

SSID: mySSID
IP Address: 123.456.7.8
signal strength (RSSI):-82 dBm
To see this page in action, open a browser to http://123.456.7.8


(I changed the IP and SSID in the above quote).

I tried using the 'Scheduled WiFi SSL Web Client for MKR1000' sketch, which still works. Curiously, when I run this code, the board's IP address does not appear in the list of devices connected to my WiFi.



RichBoud

I changed a setting on my router from WPA2 to WPA2 + WPA. I then changed it back. Now the example sketches work.

Go Up