Go Down

Topic: MKR 1010 couldn't get a wifi connection (Read 541 times) previous topic - next topic

archet

Hi, my new Arduino MKR 1010 cannot connect to any WiFi network.
I am using the ScanNetworks example just to see if it can scan the wifi networks around.
My cellphone detects 7 wifi SSID around it, but Arduino MKR 1010 says it scanned 0 networks and then stops.
I attach the image showing the serial monitor with the messages.
I have successfully done the wifiNINA firmware updater.

The very first time I tried to connect to a wifi I had to do many tries until I gave up. Oddly enough the day after I tried again using the scanNetworks example and actually it started working. I was even able to send temperature and humidity data to a Firebase database.

Now, few weeks after, I was confident it would work immediately but, unfortunately, it didn't.
Any try with the ScanNetwork example gives always the same zero scanned network result and then stops.

What can be done to take it to work? Could the board be defective?

Thanks for any advice.
 

archet

I ran once again the WIFININA firmware updater. It ended normally.
I successfully ran the blink sketch to see if the board is working, but when running the ScanNetworks sketch, it always finds zero networks and then after a while stops.

By the way,
my Arduino MKR 1010 board has a strange piece of something, that could be glue (?) coming out exactly from the WiFi antenna.
Have a look at the attached picture. Is it normal? I do not see anything like that in the images of Arduino MKR 1010 on the Amazon store, where I bought it from.

 

Go Up