Go Down

Topic: Amplifier circuit for SimpleAudioPlayer: potentiometer and sound quality issue (Read 2189 times) previous topic - next topic

meaou

I'm following SimpleAudioPlayer tutorial (https://www.arduino.cc/en/Tutorial/SimpleAudioPlayerZero) to add sound to one of my sculptures.


I followed the diagram from the tutorial and it - almost - works. I've been troubleshooting the circuit for a while to figure out what might be wrong, but I have two persistent issues that I would appreciate advice with:

1. Turning the knob of the potentiometer doesn't do anything. Judging by how quiet the speakers are, LM386 is at its lowest gain.

The potentiometer in the scheme has 3 pins in a V pattern, mine has 3 pins in a line pattern (I added an image in the attachment). As far as I understand it shouldn't make any difference. Am I wrong?


2. The sound coming from the speaker is extremely low-quality, and as far as I understand, capacitor and resistor, if wired properly, should alleviate that.

Here's a link to a video with the sound (the sound coming from the speaker is breathing) - https://drive.google.com/file/d/1Osm-Dcb6JVdk6_dLfA1FK5IVCnoBg8Pc/view?usp=sharing


Do all capacitors have to have the same or higher voltage than the first capacitor in the circuit?
Mine are the following:
1 ceramic 0.1UF capacitor
2 10 UF 25v polarized electrolytic capacitors
1 470UF 16v polarized electrolytic capacitor (the tutorial asks for 250UF, but I only have 220 and 470).


I've tried replacing all the components, checked wiring, no results. What else could be affecting the situation and maybe someone could suggest a good next step in troubleshooting?



 

zwieblum


meaou

What is your problem in the first place?
I'm trying to understand how to fix the following:

1. Turning the knob of the potentiometer doesn't do anything. I expect it to make the sound louder.

2. The sound coming from the speaker is extremely low-quality. I assume it's not supposed to be that way?

zwieblum

Sorry, without schematics it's impossinble to give good advise.

meaou

Sorry, without schematics it's impossinble to give good advise.
Here it is - https://www.arduino.cc/en/uploads/Tutorial/LM386_AudioDue.jpg

zwieblum

This won't work. Please take a look at the datashee, e.g.: https://static.chipdip.ru/lib/010/DOC003010849.pdf - page 8 gives the same schematic for fixed gain amplifier with Vin beeing AC in respect to GND - where GND is not arduino GND, it's 0V when using dual voltage supply (-V/0V/+V).
Please look ath the rasdpberrypi schematics.



Go Up