Go Down

Topic: Tool/Serial Port does not appear only Tools/Port (Read 81 times) previous topic - next topic

zeevr

I want to activate Adruino Uno with version 1.8.13 on Windows 10, but I cannot choose the port. It does not enable any options . How to solve the issue?



sterretje

Start by looking in device manager; when you connect an Arduino Uno, you should see a (new) serial port. If not, check for any (new) yellow exclamation marks (e.g. under "other devices").

If you have a clone with CH340 USB-to-TTL converter, you need to install the driver.
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

pert

Regarding the title "Tool/Serial Port does not appear only Tools/Port", there is no such thing as a "Tool/Serial Port" menu. Perhaps you are reading a tutorial somewhere that got the menu name wrong (or maybe it was named like that many years ago?).

Once you get your board correctly connected and configured, you will see its serial port listed under the Tools/Port menu (which will no longer be grey and disabled). You can achieve that by following @sterretje's excellent advice.

ballscrewbob

On windows 10 some installations HIDE the COM & LPT ports.
Enable "Show hidden devices" in device manager if you are one of those unfortunate to have that issue.

Could you also take a few moments to Learn How To Use The Forum.
It will help you get the best out of the forum in the future.
Other general help and troubleshooting advice can be found here.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google (who would have thunk it ! ) or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up