Go Down

Topic: Why, oh why? verification error, first mismatch at byte 0x00c5 0x90 != 0x94 (Read 747 times) previous topic - next topic


Check around the Reset circuit. Make sure you have around 5V on the reset lead after the sketch is loaded.

Coding Badly

buuut.. it also doesn't start.
You will have to adjust the fuses / lock bits to reflect the absence of a bootloader.


Why? Unless you want extra memory, it seems to work well here. Load the sketch using USBasp, then plug your Mega into the USB and get  your serial messages. Blinking away and dumping the message.

Blink Complete
Mega 2560 IN LOOP

Coding Badly

...it seems to work well here...
Specious reasoning.

I believe the vector table is the most important difference.  I recall something about the reset vector pointing to no-man's-land.  You know.  The bit of start up logic that, if it does not work as expected, might lead someone to post something like, "buuut.. it also doesn't start."


I changed the high fuse from D6 to D7 to indicated a lack of bootloader, with the same result. The sketch will not start. I also tried to upload it with the original Arduino 2560 board settings instead of the MegaCore one, with the same result.
So, to summarize:

- Upload over ISP works without verification error, but code will not start
- Upload via serial using the MegaCore bootloader causes a verification error, but code starts.
- Upload via serial using the stock bootloader causes RX0 to be completely non-functional

Most likely theory at this point: Goblins.

Will check the reset pin voltage in the morning.

Go Up