Go Down

Topic: RGB led Strip red LED light up even not coded. (Read 339 times) previous topic - next topic

insanul_kamil

Jul 12, 2020, 10:43 am Last Edit: Jul 12, 2020, 10:47 am by insanul_kamil
Hi! I'm using non addressable RGB LED strip. I hooked up my RGB pin to pin 9,10 and 11 at arduino Mega. I'm following this circuit for my wiring ( see attachment ) using NPN transistor. Last night all of my project is working perfectly, but today when I wake up and turn my arduino Mega on, my Red LGB Strip is light up(dim) without even do anything and when i try to get colour white, i get flickering blue and green while Red RGB not brightening or dimming.

So I tried swap that transistor on Red RGB to blue it happen again.

Any suggestion how to troubleshoot this?


PaulRB

How many LEDs on your strip?

Maybe post some pictures? Please make sure they are in strong light and well focussed, and that we can see where each wire begins and ends.

insanul_kamil

I cant post picture. Web says entity to large. The led strips is same at this web https://learn.sparkfun.com/tutorials/non-addressable-rgb-led-strip-hookup-guide/all .
My rgb led strips length is 1.4 m. 3 led on a strip.

PaulRB

#4
Jul 12, 2020, 04:32 pm Last Edit: Jul 12, 2020, 08:23 pm by PaulRB
Quote
I cant post picture. Web says entity to large
Sounds like "the dog ate my homework". Take pictures at lower resolution!

You have a 1.4m strip with only 3 LEDs on it? I think you should count those again. If you are correct, it won't take long.

CrossRoads

Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

Grumpy_Mike

If you are using strip board then there is probably a loose connection.

Any way add a 10K resistor between each Arduino output and ground. 

Go Up