Go Down

Topic: Chapter 2 Section 2.2 Connecting MATLAB to Arduino: Unable to get motor running (Read 4781 times) previous topic - next topic


I'm currently working on "Connecting MATLAB to Arduino" in section 2.2 of Chapter 2. I have already mounted the MKR1000 on top of the MKR Motor Carrier in the correct orientation, the LiPo battery is connected with the black wire going to ground, and I have my motor M+ wire connected to the M3- connection on the board and the M- wire connected to the M3+ connection on the board. When I plug in the USB cable into the MKR1000, with the motor carrier switch set to off, the orange LED directly next to the green LED beside the on/off switch flashes once. Then, when I switch the on/off switch to on, the green LED that should light up does not. I'm also unable to get the motor running even after following the code instructions. I'm not getting any errors, it's simply just not running in response to the code. I've attached two photos below of the orange LED and the lack of the green LED.

I also checked the voltages using the four pins on the end of the board. VIN read as 12.5, and the 3.3 volts is correct, but there is no reading on the 5 volt pin. I tried with the on/off switch in both positions. Is this normal? I've attached pictures of each below as well.

Any help would be greatly appreciated!


Hi, from the images I see that the red led next to the power is on. You have to update the firmware of the motor carrier by running the flasher example. Upload the flasher example, after upload open the serial monitor and wait till the message is complete. After that try the motor test example.
┗(•ˇ_ˇ•)―→ Member of the Arduino customer service team
( ━☞´◔‿ゝ◔`)━☞ Contact us through https://bit.ly/2xxu1le


I am using the MKR1000 board and Motor Carrier Shield supplied with the engineering kit and also have power related errors when following the chapter tutorial.  The LIPO battery is charged and reports >11V from a multimeter.  I updated firmware using the Arduino IDE and the Example-Flasher - this was successful.  I do not get any indication that power is on with the shield (the led does not light when I toggle the switch).  The motor_test example reports that I am running firmware V0.11 and stops because the battery voltage is too low - reporting I have 3.00V available.  Any suggestions for why the LED is not turning on so the motor driver shield can operate? 

Thank you so much, I look forward to using this kit with some high school engineering students, but can not have this much frustration with an early task.


Hi, from what you are saying it seems like the carrier is not taking any power from the battery. Can you write to us at support@arduino.cc and we can have a look at what is happening with carrier.
┗(•ˇ_ˇ•)―→ Member of the Arduino customer service team
( ━☞´◔‿ゝ◔`)━☞ Contact us through https://bit.ly/2xxu1le


The image with the Orange LED is from a screenshot of a video I had taken. It flashes on only for one second while plugging in the USB. However, I went ahead and tried what you suggested, but I'm still not having any luck. I ran the Flasher example and the serial monitor printed that it is running on version 0.11. Then I tried the Motor Test example and the serial monitor printed,

"MKR Motor Shield connected, firmware version 0.11
Battery voltage: 0.00V, Raw 5

Despite the message saying the battery is low, I checked the voltage on the battery, and it is fully charged.

Any suggestions for what I should try next?


After reaching out to customer service and not getting a response, I decided to purchase a new MKR Motor Carrier myself. After receiving it, I followed the exact same protocol as I described above, I tested the example out again, and it works! Feeling a bit disappointed that Arduino sent me a defective board. Will be contacting their customer service to see if I can get a refund for the extra $56 I just spent on top of the $300 price of this kit.


I have the exact same problem. I cannot get the dc geared motor to run when following Example 2.2 in Chapter 2 of the Engineering Kit.
(The Chapter is completely outdated for Matlab R2020a but this is a different issue).

Even without Matlab, running the MKRMotorCarrier Examples inside the Arduino IDE report:

Battery voltage: 0.00V, Raw 0

Even though my LiPo is completely charged and the switch in the MKRMotorCarrier is On.

Are many of the MKRMotor Carrier Boards in the Engineering Kits defect?
I do not want to spend another 50 Euros on top if what I already spent for the kit?

Is buying a new motor carrier the only solution?

When I run the Flasher example in the Arduino IDE, it tells me:
MKR Motor Shield connected, firmware version 0.06

Thanks for your help.

Go Up