Go Down

Topic: Goodbye Arduino- Editor won't connect (Read 100 times) previous topic - next topic

Monsterthews

This is unfortunately the continuation of a theme.

I got my bluetooth chips today, and I've been collecting scripts. Finally got a chance to use example scripts from BLE in Editor, and OF COURSE they don't work. I had to define an IO pin. And then I had to delete two functions that called for something the writers failed to include, or whatever. But I got it to compile, and now it doesn't see my Uno. Okay, so I tried the Nano, and the same thing happened- nothing.

I can't use any of my other boards with Arduino anymore, and it quit working on my brand-new PCR. So I've been avoiding Arduino. But I haven't figured out PlaformIO yet, and I wanted to trust that Arduino would help me.

But now I can't connect. I can't possibly figure out why, and I'm pretty sure nobody is going to try to help me. This forum has been a waste for me. Every other open source meeting place is better for community help, as far as I've seen.

So this stinks. I have a big investment in this hobby, that I got through Arduino, and I'm being handicapped at every stage of my growth.
So I guess this is goodbye. I'll have to cancel my membership. I'm a paying member. I'm really upset that your products don't work, and I have no way of ever understanding why or fixing them.

pert

Finally got a chance to use example scripts from BLE
Please provide a detailed explanation of what you mean by "BLE".

in Editor
Please provide a detailed explanation of what you mean by "Editor".

now it
Please provide a detailed explanation of what you mean by "it".

doesn't see my Uno
Please provide a detailed explanation of what you mean by "doesn't see".

so I tried the Nano, and the same thing happened- nothing.
Please provide a detailed explanation of what you mean by "nothing".

it quit working on my brand-new PCR
Please provide a detailed explanation of what you mean by "PCR".

This is unfortunately the continuation of a theme.

...

I'm pretty sure nobody is going to try to help me. This forum has been a waste for me.
It certainly is a continuation of a theme. The theme is that you make vague posts on the forum with a negative attitude, the forum members try to help, then you never bother to respond. We are here to help, but we can only do that if you provide the necessary information and are responsive. This is 100% on you.

If you set out with the intention to have a bad experience with Arduino, well you're going get just that. Millions of others have had a good experience with Arduino and there's no reason you can't be one of them.

sterretje

#2
Aug 02, 2020, 07:19 am Last Edit: Aug 02, 2020, 07:20 am by sterretje
For 328P based boards like Uno / Nano / ProMini as well as on the Mega, you can not upload if you connect the bluetooth module to pins 0 and 1.

Maybe that's your problem.
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

Coding Badly

#3
Aug 02, 2020, 07:49 am Last Edit: Aug 02, 2020, 07:49 am by Coding Badly
Apr 11, 2020: Boards disappeared from Arduino IDE
One person tries to help.  No reply.

Apr 26, 2020: Big Problem: AVRDUDE, Not In Sync- what is this???
One person tries to help.  No reply.

Jun 19, 2020: New Arduino IDE 1.8.13 can't add boards
Two people try to help.  No reply.

Jun 26, 2020: Now Arduino fails to run in Windows.
One person tries to help.  No reply.

Jul 12, 2020: Old code doesn't work- Adafruit OLED
One person tries to help.  No reply.

Jul 18, 2020: Converting Arduino's C++ to proper C++
Three people try to help.  No reply.

Jul 22, 2020: Why no boards????
Two people try to help.  No reply.

Jul 22, 2020: What the heck is going on with Example scripts not working in Arduino Editor???
One person tries to help.  No reply.

Aug 01, 2020: Goodbye Arduino- Editor won't connect
Two people try to help.  No reply.


Coding Badly

#4
Aug 02, 2020, 07:52 am Last Edit: Aug 02, 2020, 07:52 am by Coding Badly

Which leaves just one question for you @Monsterthews.

Are you human?

If you fail to reply within a reasonable time I have to assume you are an incompetent FUDbot in which case your account will be banned.


Go Up