Go Down

Topic: Problem bei der Anmeldung im Forum (Read 1 time) previous topic - next topic

DerLehmi

Scheint ja doch arge Probleme zu geben...
Bei mir tritt bisher nur öfters auf, dass mich das Forum scheinbar ausloggt. Klicke ich auf Sign In, werden ab und an keine Anmeldedaten abgefragt, sondern ich werde direkt eingeloggt. Noch nicht so heftig, dass das Forum für mich unnutzbar wäre

my_xy_projekt

#16
Sep 06, 2020, 09:12 pm Last Edit: Sep 06, 2020, 09:13 pm by my_xy_projekt
so nach und nach melden sich immer mehr, es sind nicht immer die gleichen "Meckerer".
Ja, zum Glück.
Aber vermutlich ist es noch nicht aufgefallen - mir aber schon.
Tataaa!


Die Leiste erscheint jetzt beim Board-Aufruf.
Ich find's Unnütz.
Mache sich jeder sein Eigenes Bild davon.

Mit dem Layout verbunden sind dom(-Objekte) für youtube, twitter, instagram facebook etc.pp.
Das mag nichts neues sein, aber mal nachdenken:

„Facebook hat uns in einem Brief geschrieben, dass sie weiter Daten [in die USA] schicken werden, auch wenn das Urteil ihnen das untersagt hat"
(ggfls. temporärer Vorschalthinweis)

Hm.
Quote
c't habe ich.   ;)    Leider sinkt das Artikel Niveau auch nach und nach. Das Niveau aus der Zeit der Monatsausgaben wo man sich mit jeder Ausgabe die Knie gebrochen hat, wird wohl nie wieder erreicht werden. Das waren noch Fachartikel die man mehrfach lesen musste. Man merkt die neue Generation der Redakteure. Aber das ist ein anderes Thema.
Solange, wie da oben auf der Titelseite "Europas***" drauf steht, soll es so sein. Ich glaub schon spätestens seit der Reduktion der Seiten nicht mehr dran. Und eine nicht gezählte, aber doch erhebliche - nicht inserierende - Anzahl Werbepartner wohl auch nicht.


DrDiettrich

Was mir desöfteren noch auffällt ist die zweite Seite eines Forums, die mir zu oft leer (gelesen) angezeigt wird wenn die erste Seite komplett voll (new) ist.
Das wurde anscheinend in den letzten Tagen behoben, jetzt kommt es kaum noch vor, daß die zweite Seite keine ungelesenen Einträge enthält. Ob hier das Meckern etwas genützt hat?

uwefed

Ich wurde von der Umstellung der Menuleiste genauso überrascht wie Ihr. Ich nehme mal an die Probleme sind auf die Umarbeitung zurückzuführen.
Grüße Uwe

Doc_Arduino

#19
Sep 09, 2020, 10:27 am Last Edit: Sep 09, 2020, 10:31 am by Doc_Arduino
Hallo,

ich habe selbst eingloggt Probleme immer die aktuelle Seiten zu sehen. Ich antworte in einem Thread und dann ist dieser auf der ersten Seite verschwunden. Dann fängt das geklicke mit Refresh wieder an. Das ist ehrlich gesagt unerträglich. Gerade jetzt wieder erlebt. Mein Avatar ist mal da und dann wieder weg. Diese "Anzeige" ist reines Glücksspiel. Wenn ich den Thread gefunden habe, gehe ich rein und es ist alles aktuell, wenn ich eingeloggt bin. Gehe ich wieder auf die "deutsche Haupseite", ist wieder alles durcheinander. Ich benötige irgendeinen Thread worin mein Avatar sichtbar ist zum ausloggen. Sonst sehe ich nur "Sign". Völlig unlogisches Verhalten. Warum - keine Ahnung.
Tschau
Doc Arduino '\0'

Messschieber auslesen: http://forum.arduino.cc/index.php?topic=273445
EA-DOGM Display - Demos: http://forum.arduino.cc/index.php?topic=378279

my_xy_projekt

Gerade jetzt wieder erlebt. Mein Avatar ist mal da und dann wieder weg. Diese "Anzeige" ist reines Glücksspiel. Wenn ich den Thread gefunden habe, gehe ich rein und es ist alles aktuell, wenn ich eingeloggt bin. Gehe ich wieder auf die "deutsche Haupseite", ist wieder alles durcheinander.
Seit ich cloudfare ausblende, ist das nicht mehr ganz so schlimm - vor ca. 20-25 Minuten ist aber wieder einmal ein loadbalancing durcheinandergekommen und Firefox quittiert das mit einem "PR_END_OF_FILE_ERROR".
Danach scheint der Sessioncookie verloren zu sein - also gehts auf die Forumhauptseite..
Schick ist anders.

Moko

vor ca. 20-25 Minuten ist aber wieder einmal ein loadbalancing durcheinandergekommen und Firefox quittiert das mit einem "PR_END_OF_FILE_ERROR".
Danach scheint der Sessioncookie verloren zu sein - also gehts auf die Forumhauptseite..
Schick ist anders.
Das hatte ich gestern abend über ca 30-45 min :(

agmue

Auch wenn sich die Optik verändert hat, so bleibt das von mir beschriebene Verhalten leider unverändert.

Die Vorstellungskraft ist wichtiger als Wissen, denn Wissen ist begrenzt. (Albert Einstein)

DrDiettrich

Inzwischen flutscht bei mir alles wie erwartet, eingeloggt ins Forum mit FF unter WinXP.

Unter Win8.1 sind die Listen nicht aktuell (2-3h hinterher), nicht eineloggt.

Welche Systeme und Browser benutzt ihr denn, die so viel mehr Fehler zeigen? Wobei es eigentlich nicht am Browser liegen kann, wenn der Server kaputte Listen anliefert.

my_xy_projekt

Wobei es eigentlich nicht am Browser liegen kann, wenn der Server kaputte Listen anliefert.
Doch, doch.
wenn Du mit einem FF mit Einstellung "Cookies und Website-Daten beim Beenden von Firefox löschen" am Tage erstmals das Board aufrufst und dich nicht einloggst sind die letzten Beiträge recht aktuell.

Das ändert sich dann aber recht schnell - sodas irgendwann ca. 2Std Versatz zwischen geschriebenem Beitrag und Anzeige in der Übersicht auffallen.
Sobald eingeloggt stimmt die Aktuallität wieder.

Oftmals kommt auch - im nicht eingeloggten Zustand - in der Übersicht eine aktuelle Liste, wenn Du einen Beiträg öffnest, endet der Thread mittendrin.
Da hilft dann, das Topic anders aufzurufen. Aus:
https://forum.arduino.cc/index.php?topic=704324.0
wird dann z.B.:
https://forum.arduino.cc/index.php?topic=704324.18
Das hinter dem . muss irgendwas größer als die Anzahl der Antworten sein.

Quote
Welche Systeme und Browser benutzt ihr denn, die so viel mehr Fehler zeigen?
Ubuntu 18.04 LT mit FF derzeit 79.0
Windows 7 mit FF ESR - auch aktuell
TOR-Browser 9.5.4 - und da läufts noch am Besten.
Alle mittlerweile mit ublockOrigin und eigener angepasster Filterliste.
Je nach Standort mit eigenem DNS und/oder Zwangsproxy.





combie

#25
Sep 09, 2020, 01:09 pm Last Edit: Sep 09, 2020, 01:16 pm by combie
Hach...

Was da passiert ist doch offensichtlich.
Einen ersten Nachweis findet man in den HTTP Headern: Unterschiedliche Cache Strategien.


Der Zweck/Grund ist ebenso offensichtlich und berechtigt:
Ressourcen sparen, z.B. DB-, WebServer-, Netzwerklast

Also, alles ok.
Bis auf die unbefriedigte Gier, unangemeldeter Nutzer, welche selber nicht bereit sind den Serverpark zu bezahlen.

Klarer:
Es geht mir vollkommen am Arsch vorbei, was unangemeldeter Nutzer sehen!
Hauptsache, für mich geht es schnell.
Und das tut es.

Keine Anmeldeprobleme, zügige Serverresponse. Alles gut hier.
Opera + Win 10

Ich bin Dankbar.
Heute war Gestern Morgen.
Heute ist Morgen Gestern.
Morgen ist Heute Gestern.
Gestern war Heute Morgen

Doc_Arduino

#26
Sep 09, 2020, 02:20 pm Last Edit: Sep 09, 2020, 02:23 pm by Doc_Arduino
Hallo,

deine Aussage ist ja vollkommen daneben und ohne irgendwas wirklich gesagt zu haben.
Nachdem Motto, Hauptsache ich, niemals die Anderen.

Was soll es technisch für einen Unterschied machen ob man angemeldet ist oder nicht? Wenn der Browser eine Seite anfordert will er aktuelle Daten haben.

Und seit wann zahlt ein angemeldeter User die Servermiete für Arduino.cc?

Um Serverlast zu sparen stimmt das Cacheverhalten auch nicht überein. Dann müßte ich den alten Stand sehen. Der stimmt aber nicht, weil alles durcheinander ist, die Beiträge haben den falschen Zeitstempel und sind damit nicht sauber sortiert.

combie, mal ehrlich, dein Beitrag ist unter aller Kanone.
Tschau
Doc Arduino '\0'

Messschieber auslesen: http://forum.arduino.cc/index.php?topic=273445
EA-DOGM Display - Demos: http://forum.arduino.cc/index.php?topic=378279

combie

#27
Sep 09, 2020, 02:27 pm Last Edit: Sep 09, 2020, 02:31 pm by combie
Quote
Was soll es technisch für einen Unterschied machen ob man angemeldet ist oder nicht? Wenn der Browser eine Seite anfordert will er aktuelle Daten haben.
Du weißt also nicht um die Wirkungen der Cache Header.
Magst dich auch nicht wirklich kundig machen.

Bestreitest den Willen und  Absicht des Seitenbetreibers, den angemeldeten Usern mehr Ressourcen zur Verfügung zu stellen, als anonymen Gästen.

Dass dieses zudem ein übliches Verfahren ist, naja, ist dir auch fremd.


Und ja:
Ich bin dem Betreiber dankbar dafür, dass er das so abhandelt.
Von Herzen.
Heute war Gestern Morgen.
Heute ist Morgen Gestern.
Morgen ist Heute Gestern.
Gestern war Heute Morgen

DrDiettrich

Dem Server macht es doch mehr Arbeit, wenn er zwischen eingeloggten Benutzern und Gästen unterscheiden muß. Ich lese im einen System als Gast, damit nicht alles gleich als gelesen und zur Wiedervorlage markiert wird. Wenn es sich dann lohnt, meinen Senf zu einem weiteren Topic zu geben, dann gehe ich in die eingeloggte VM und antworte dort.

Sag mal, Combie, bekommst Du irgendwas dafür, daß Du die Forumsoftware gegen jegliche Kritik in Schutz nimmst? Oder bist Du es selbst, der da dran rumfummelt und seine Fehler kleinreden muß? :-]

combie

Quote
Sag mal, Combie, bekommst Du irgendwas dafür, daß Du die Forumsoftware gegen jegliche Kritik in Schutz nimmst? Oder bist Du es selbst, der da dran rumfummelt und seine Fehler kleinreden muß? :-]
Die ehrliche Antwort: Nein und Nein!


Quote
Dem Server macht es doch mehr Arbeit, wenn er zwischen eingeloggten Benutzern und Gästen unterscheiden muß.
Das genaue Gegenteil ist der Fall.

Gäste werden bevorzugt aus dem Cache bedient.
Eigentlich ist es eine Kette von Caches.

Ich drösele sie mal rückwärts auf:
Der Browser Cache
Der Provider Cache (gerade bei Funknetzen sehr aggressiv)
Cloudflare
Proxy/Loadbalancer
(keine Garantie auf Vollständigkeit)

Die HTTP Header bestimmen das Verhalten der Caches.

Die meisten Anfragen kommen gar nicht bis zum Server durch, sondern werden von irgendeinem der Caches befriedigt.

Quote
Dem Server macht es doch mehr Arbeit, wenn er zwischen eingeloggten Benutzern und Gästen unterscheiden muß.
Ich hoffe, dass ich darlegen konnte, dass dieses nicht wahr ist.
Heute war Gestern Morgen.
Heute ist Morgen Gestern.
Morgen ist Heute Gestern.
Gestern war Heute Morgen

Go Up