Go Down

Topic: Problem bei der Anmeldung im Forum (Read 1 time) previous topic - next topic

Doc_Arduino

#30
Sep 09, 2020, 03:47 pm Last Edit: Sep 09, 2020, 03:50 pm by Doc_Arduino
Hallo,

Du verdrehst die Worte!
Quote
Bis auf die unbefriedigte Gier, unangemeldeter Nutzer, welche selber nicht bereit sind den Serverpark zu bezahlen.
Gebe zu das diese Aussage Unsinn ist! Weder angemeldete noch unangemeldete User tragen irgendwas zu den Serverkosten bei. Wäre auch Nonsens, weil niemand weiß welcher User originale Boards gekauft hat und welche nicht.

Wegen deiner Aussagen zum Cache und angemeldet muss das alles funktionieren. Genau das widerlege ich. Auch angemeldet funktioniert das nicht richtig. Steht alles in diesem Thread und älteren Threads zum Thema.

Du gehst immer von dir aus, weil es bei dir zufällig funktioniert. Schön. Deswegen musste jetzt nicht zum Rundumschlag ausholen das wir alle zu blöd sind und das Scheiß Webseitenverhalten verdient hätten. Denn wenn wir nicht angemeldet wären könnten wir hier nicht schreiben. Laut deiner falschen Logik tragen wir alle hier bei und werden trotzdem mies von der Webseite behandelt. Deine Cache Logik haut demnach hinten und vorne nicht hin.

Edit:
Aktuell teste ich jetzt Opera.
Tschau
Doc Arduino '\0'

Messschieber auslesen: http://forum.arduino.cc/index.php?topic=273445
EA-DOGM Display - Demos: http://forum.arduino.cc/index.php?topic=378279

Tommy56

Genau das widerlege ich. Auch angemeldet funktioniert das nicht richtig. Steht alles in diesem Thread und älteren Threads zum Thema.

Du gehst immer von dir aus, weil es bei dir zufällig funktioniert. Schön.
Also nach dem ersten Refresh nach dem Anmelden funktioniert es auch bei mir jederzeit problemlos, solange der Server nicht wiedermal tot ist.
Es kann also eher kein Zufall sein.

Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

my_xy_projekt

Die meisten Anfragen kommen gar nicht bis zum Server durch, sondern werden von irgendeinem der Caches befriedigt.
Die Erläuterung wird nicht mal angezweifelt.
Rein die Schlußfolgerung ist falsch.
Das Vorhalten eines Caches UND die Bearbeitung der Anfragen Serverseitig sowie deren Beantwortung dieser aufgrund des Einsatzes von Clientseitigen Scripten erhöht die Last.

Es darf egal bleiben ob ein Proxy die Anfrage beantwortet oder der Server selbst.
Praktisch könnte jede beantwortete Anfrage im Proxy verbleiben und von dort erneut ausgeliefert werden.
Wird es aber nicht. Es verbleiben im Cache unterschiedliche Versionen des ausgelieferten Materials.
Cloudflare "würfelt" egal ob eingeloggt oder nicht, was ausgeliefert wird - offensichtlich je nach Gusto, wo der Exit ist.

solange der Server nicht wiedermal tot ist.
Es kann also eher kein Zufall sein.
Und das merken auch die jenigen, die einen Cloudflare Error 502 erhalten, wenn Sie nicht eingeloggt sind.

DrDiettrich

Die meisten Anfragen kommen gar nicht bis zum Server durch, sondern werden von irgendeinem der Caches befriedigt.
Ich hoffe, dass ich darlegen konnte, dass dieses nicht wahr ist.
Sorry, das ist nicht stichhaltig. Wenn ich in meiner VM und im Host System unterschiedliche Seiten zum selben Forum angeboten bekomme, dann steckt da doppelte Arbeit und Platz drin, statt daß jeder Cache nur die aktuelle Version jeder Seite enthält.

Es wird also umgekehrt mehr Traffic generiert und Cache belegt als tatsächlich notwendig. Das läßt sich allenfalls mit einem Versuch begründen, die Benutzer mit Gewalt zu verarschen, koste es was es wolle :-(

combie

Quote
Gebe zu das diese Aussage Unsinn ist! Weder angemeldete noch unangemeldete User tragen irgendwas zu den Serverkosten bei. Wäre auch Nonsens, weil niemand weiß welcher User originale Boards gekauft hat und welche nicht.
Habe ich das je behauptet?

Der Webserverbetreiber zahlt für den Serverpark.

Also hat dieser auch jegliches Recht, zu bestimmen, wer zügig/aktuell bedient wird.
Um Kosten zu sparen, werden angemeldete User bevorzugt.



Quote
Deine Cache Logik haut demnach hinten und vorne nicht hin.
Die ist doch nachweisbar!
Musst nur hinschauen.


Quote
Du gehst immer von dir aus, weil es bei dir zufällig funktioniert. Schön.
Was bei dir nicht funktioniert, oder warum, kann ich dir natürlich nicht sagen.
Sitze ja auch nicht an deinem Ende des Internet.

Falls du es nicht bemerkt hast...
Mein Erklärung bezieht sich ausschließlich auf das angemäckerte Cachverhalten.
Dachte ich hätte ausführlich dargelegt, dass dieses Verhalten beabsichtigt ist.
Dass ich es begrüße.
Für richtig halte.


Quote
Sorry, das ist nicht stichhaltig. Wenn ich in meiner VM und im Host System unterschiedliche Seiten zum selben Forum angeboten bekomme, dann steckt da doppelte Arbeit und Platz drin, statt daß jeder Cache nur die aktuelle Version jeder Seite enthält.
Keine Ahnung, was du damit meinst.

> Wenn ich in meiner VM und im Host System
Dann sind da schon mal 2 Browser und 2 Caches im Spiel.
Wenn die beiden Browser bei gleicher Adresse unterschiedliche Seiten zeigen ist das der BEWEIS dafür, dass wenigstens eine der Anfragen nicht zum Server durchgegangen ist.
Also wird der Server geschont, und ich bekomme mehr Rechenzeit.

Heute war Gestern Morgen.
Heute ist Morgen Gestern.
Morgen ist Heute Gestern.
Gestern war Heute Morgen

my_xy_projekt

Wenn die beiden Browser bei gleicher Adresse unterschiedliche Seiten zeigen ist das der BEWEIS dafür,
NEIN.
Und das weisst Du.

Tommy56

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

my_xy_projekt

#37
Sep 09, 2020, 05:08 pm Last Edit: Sep 09, 2020, 05:13 pm by my_xy_projekt
Beweis durch Behauptung?
Was willst Du hören?

Jede Anfrage geht bis zum Server durch.
Die BEANTWORTUNG erfolgt dann je nach den Gegebenheiten.
Die Gegebenheiten sind u.a.: Cookie, Scripte, Headerinhalte der HTTP-GET Anfragen

Egal ob ich einen VM-HOST oder einen VM-Client nutze, nslookup auf forum.arduino.cc löst auf die GLEICHE IP-Adresse auf (vorausgesetzt, ich nutze nicht IP6 und IP4 gemischt)

Selbst wenn ich aus einem Netzwerk mit mehreren realen, physischen Maschinen das mache, gehen die Anfragen an einen und den selben Server - die Rückgabeinhalte sind aber unterschiedlich.

Hatte ich das nicht vor Wochen schon mal mit einem wireshark-test beschrieben?

Damit geht die Anfrage auch dahin.

combie

#38
Sep 09, 2020, 05:14 pm Last Edit: Sep 09, 2020, 05:16 pm by combie
Quote
Jede Anfrage geht bis zum Server durch.
Irrationaler Blödsinn!

Du willst mir weis manchen, dass der Browsercache und der jeweilige Proxy gar nicht existieren, bzw. völlig nutzlos und ohne jede Wirkung sind?

Quote
Egal ob ich einen VM-HOST oder einen VM-Client nutze, nslookup auf forum.arduino.cc löst auf die GLEICHE IP-Adresse auf (vorausgesetzt, ich nutze nicht IP6 und IP4 gemischt)
Du sprichst von DNS
Und ich spreche über das HTTP Protokoll.

Kennst du den Unterschied?
Wohl nicht, denn sonst würdest du nicht beides in einen Topf werfen.

Heute war Gestern Morgen.
Heute ist Morgen Gestern.
Morgen ist Heute Gestern.
Gestern war Heute Morgen

my_xy_projekt

#39
Sep 09, 2020, 05:29 pm Last Edit: Sep 09, 2020, 05:37 pm by my_xy_projekt
Du willst mir weis manchen, dass der Browsercache und der jeweilige Proxy gar nicht existieren, bzw. völlig nutzlos und ohne jede Wirkung sind?
habe ich das?
Quote
Du sprichst von DNS
Und ich spreche über das HTTP Protokoll.
Und ich spreche über den Datenverkehr.
Du hast behauptet, das Anfragen garnicht zum Server durchkommen.
Das ist falsch.
Jede (erste) Anfrage an forum.arduino.cc löst erstmal eine DNS-Anfrage aus.
Zurück kommt eine Adresse. Und eine TTL.
Ist die TTL abgelaufen wird erneut gefragt - solange gehen ALLE http-get erstmal an (aktuell)
forum.arduino.cc.cdn.cloudflare.net -  104.22.48.75

Zurück kommt Inhalt.
Im INHALT steht, ob und was local gecacht werden darf und wie lange nicht erneut geprüft werden muss (ob sich der Inhalt verändert hat).

Ich denke, ich weiss sehr wohl den Unterschied zwischen DNS und HTTP(s) - aber da gibt es noch ein wenig mehr.

[edit]
Wenn der Browsercache gelöscht wird, müsste (auch im ausgeloggtem Zustand) neuer Inhalt kommen. Kommt nicht. Warum wohl.
[/edit]

combie

Quote
Wenn der Browsercache gelöscht wird, müsste (auch im ausgeloggtem Zustand) neuer Inhalt kommen. Kommt nicht. Warum wohl.
Gähn....
Weil da noch mehr Caches in der Kette liegen...

Heute war Gestern Morgen.
Heute ist Morgen Gestern.
Morgen ist Heute Gestern.
Gestern war Heute Morgen

my_xy_projekt

Gähn....
Weil da noch mehr Caches in der Kette liegen...
Gähn...
Jede Anfrage geht an forum.arduino.cc.cdn.cloudflare.net -  104.22.48.75

Tommy56

Aha, an einen Cache und nicht an forum.arduino.cc

Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

my_xy_projekt

Aha, an einen Cache und nicht an forum.arduino.cc
War das an mich gerichtet?
Was glaubst Du denn, was heraus kommt, wenn Du bei Dir ein nslookup auf forum.arduino.cc startest. Alternativ dig.
Das IST der Server. Stichwort AWS S3.

combie

Gerne genommen, werden auch transparente Proxies.
z.B. Squid ist/war da sehr beliebt.

Diese lassen sich überhaupt nicht nachweisen, wenn sie freiwillig keine Header zur Erkennung mit senden.
Heute war Gestern Morgen.
Heute ist Morgen Gestern.
Morgen ist Heute Gestern.
Gestern war Heute Morgen

Go Up