Go Down

Topic: Besoin d'avis sur un projet  (Read 1 time) previous topic - next topic

trimarco232

#15
Sep 21, 2020, 09:58 pm Last Edit: Sep 21, 2020, 10:05 pm by trimarco232
la 2ème capture ressemble fort à un paquet série de 3 x 8bits (avec S et T) ; sûr à 99%


al1fch

#16
Sep 22, 2020, 06:23 pm Last Edit: Sep 22, 2020, 06:38 pm by al1fch
Bonjour

Plutot que des images avec des decodages pas vraiment appropriés mieux vaudrait déposer un enregistrement brut de plusieurs secondes a 1MHz. Ça permettrait a d'autres personnes utilisant Pulseview  de tester divers décodages et probablement d'en trouver un qui a du sens.

L'intérêt de l'analyseur loqique c'est aussi la possibilité de chercher a plusieurs au lieu de tester plein de choses , sans expérience, dans son coin ... Jusqu'au découragement.

Ce we je peux examiner un enregistrement binaire brut sous divers angles.

trimarco232

et probablement d'en trouver un qui a du sens.
euh, il n'a pas de sens "mon" crobard ?

al1fch

#18
Sep 23, 2020, 12:02 am Last Edit: Sep 23, 2020, 12:12 am by al1fch

@trimarco232
si,  mais je préfère travailler sur des données non interprétées ... probablement  pour arriver à la même conclusion !!

je ne suis pas à l'aise avec les copies d'écran fournies et n'ai pas compris ce que tu appelles '2e capture'

Il est il me semble plus intéressant de fournir un fichier d'enregistement que chacn peut présenter comme il le souhaite avec le logiciele ayant servi à faire la capture

Artouste

Bonjour

Plutot que des images avec des decodages pas vraiment appropriés mieux vaudrait déposer un enregistrement brut de plusieurs secondes a 1MHz. Ça permettrait a d'autres personnes utilisant Pulseview  de tester divers décodages et probablement d'en trouver un qui a du sens.

L'intérêt de l'analyseur loqique c'est aussi la possibilité de chercher a plusieurs au lieu de tester plein de choses , sans expérience, dans son coin ... Jusqu'au découragement.

Ce we je peux examiner un enregistrement binaire brut sous divers angles.
bonjour
+1
le salae est connecté où ? comment ?
d'aprés ce que j'ai compris de la lecture, ce serait sur la prise "MIDI (DIN5 Femelle) de l accordeon ?
on detecte bien du MIDI cohérent MIDI OUT en sortie de l'accordeon et de l'activité par encore determinée sur  le pin MIDI IN


trimarco232

la 2ème capture c'est : sur cava.png
je l'ai reprise en recopiant en dessous le 1er byte sous les 2èmes et 3èmes bytes, pour montrer le rythme
on voit clairement qu'on a bien affaire à un format série !
il n'y a donc plus qu'à déterminer le bitrate en fonction de la largeur des bits ; je pense alors qu'à ce stade tapi n'a plus besoin de nous (ni d'avoir à nous fournir d'autres éléments) pour faire son rétro protocole
(et que d'ailleurs c'est peut-être pour cela qu'il ne donne plus signe de vie)

al1fch

#21
Sep 23, 2020, 11:03 pm Last Edit: Sep 23, 2020, 11:05 pm by al1fch
Bonsoir
le dernier message de tapi se terminait sur ces mots
Quote
Si vous êtes fatigués de me répondre, je comprends complètement, je pense que je ne vais pas tarder à laisser tomber, c'est trop compliqué pour moi
d'où la proposition de communication du fichier .sr de l'enregistrement  mais qui sait il a peut être , depuis, abouti (sans le dire) avec ta proposition @trimarco232 ?

trimarco232

oui, restons optimistes, ça protège

tapi

AAAhhhh,

j'avais pas mal de travail cette semaine et je n'étais pas repassé sur le forum, quel bonheur de voir toute cette effervescence !!! Vous êtes magnifiques ;-)

Alors je vais reprendre sérieusement les tests, ce soir, je reconnecte tous mes petits câbles et j'enregistre en 1Mhz sur plusieurs secondes au format .sr.

Je vous poste ça dans la soirée

Bon dimanche à tous

tapi

Bonsoir,
Encore désolé de ne pas être repassé avant,
voilà j'ai refait une analyse en 1Mhz et en sample de 5M.

Artouste, pour te répondre, j'ai pris une photo de mon installation (probablement douteuse pour bon nombre d'entre vous ;-) sur l'analyseur, j'ai la masse de connectée (fil gris ) en GND et les deux fils de données en channel 1 et channel 2.

Pour le test, j'ai utilisé les différentes commandes de l'accordeon, changement de son, appuis sur les notes et déclenchement de séquences musicales.

La piste "commandes midi in "doit correspondre aux informations d'affichage de l'écran de l'accordéon lorsque l'on change de son. Pour preuve, Si je déconnecte le fil que je nomme "commande midi in", lorsque je change de son sur l'accordéon, le son en sortie du module change mais l'écran de l'accordéon affiche "pas de communication".

Trimarco22, tu dis que la 2ème capture ressemble fort à un paquet série de 3 x 8bits (avec S et T),S et T c'est quoi : start stop ,? 
J'ai observé les signaux de la ligne "notes out"et on dirait qu'il y a toujours trois séries entrecoupées d'une série qui dure toujours le même temps et qui est toujours 0.
Pour la première série, je n'ai relevé que trois commandes différentes (en midi ou uart) : cc, cb ou dc mais majoritairement cb.  En tout cas, il a beau être insistant, je ne lui donnerais pas ma carte bancaire !!!
Bon je pense que vous analyserez ça 100 fois mieux que moi.

En tout cas cette semaine, je vais pouvoir m'y remettre.

Bonne semaine à tous et merci



tapi

Outch, j'ai parlé trop vite, la deuxième série peut être différente, elle n'est pas toujours sur 0. Désolé

tapi

je galère avec les pièces jointes...


trimarco232

#27
Sep 27, 2020, 11:47 pm Last Edit: Sep 27, 2020, 11:49 pm by trimarco232
(...)
Trimarco22, tu dis que la 2ème capture ressemble fort à un paquet série de 3 x 8bits (avec S et T),S et T c'est quoi : start stop ,?
(...)
oui, en abrégé (comme sur la 3ème capture, je n'ai rien inventé)
-> mesures la durée d'un bit : en inversant la valeur tu auras le baudrate (bps) qui te permettra d'observer et de décoder tes trames

tapi

Effectivement en mesurant avec le zoom au maximum, j'ai 8µ tout pile. Sur les tableaux que je trouve, pour 115200 ils disent 8.681µ. C'est normal que ça varie un peu ? peut-être l'analyseur qui n'est pas assez précis ? ou alors on peut affiner le reglagle du baudrate ?

Autre question, est ce que le frame error que j'ai sur une majorité de message au même niveau que les stop vient du fait que je n'ai pas bien règler mon decodeur uart ? ou alors que ça n'est pas de l'uart ?

5_cylindres

bonsoir,

... j'ai 8µ tout pile. ... pour 115200 ils disent 8.681µ. C'est normal que ça varie un peu ? peut-être l'analyseur qui n'est pas assez précis ?
l'analyseur travaille à sa propre vitesse : il te donne les temps qu'il a relevés.
si tu prends un autre bit, il sera peut-être mesuré à 9µs, ou 12, suivant l'horloge d'acquisition de l'appareil.

si tu veux avoir "une vraie mesure", il faut prendre une "longue" plage et diviser par le nombre de bits reçus.

exemple : si 100 bits durent 868µs, 1 seul vaudra bien 8.68, même si la résolution de l'analyseur n'est que de 4µs.

Go Up