Go Down

Topic: Ethernet Shield - serious problems! (Read 4431 times) previous topic - next topic


I've got an Arduino Uno (ATMEGA328P) with an ethernet shield stacked on top (ENC28J60 Ethernet Shield); and have not been able to get the ethernet shield working at all!

I've stacked the ethernet shield, pluged the USB and uploaded the webserver sketch found in the 'Example' sketch library on the device. The MAC address has been kept the same as specified (my shield had no printed mac) and I have cycled through so many IP addresses I think I've actualy lost my way home.

When I plug the ethernet to my router (ive tried two sky netgear routers, and a belkin) it is not recognised. The Belkin router "wired" connection lights up, as does the netgear ones, but it lights up an amber light which indicates that there is a wire but no connection.

On the Arduino itself it holds a green light on the ethernet connector and a flashing amber light. I'm so confused, I figured at first it was an IP issue, but after finding local IP address, and cycling through unnamed addresses I still have no hope. When the home address is Ive tried unnamed addresses - and no hope. This is the same with other addresses used on the other routers where the home address is and The board does not appear in any of the routers' "attached devices" lists.

Please can someone help me on this? Is my ethernet shield just dead or something? I'm at my wits end right now, and I know you loverly people are my best hope at getting to the end of this head-scratcher!


What O.S. are you using to program the Uno? Windows or Linux?


I'm programming in a Linux, Ubuntu enviroment. I've successfuly uploaded sketches and tinkered around with the Arduino on it's own, but it just doesnt seem to work with the shield stacked.


Aug 27, 2011, 09:31 pm Last Edit: Aug 27, 2011, 09:46 pm by SurferTim Reason: 1
I just finished having problems with the Linux version compiler and the ethernet shield on a Mega2560, but the bug and solution would apply to the Uno also. Here is that thread:

I used a Windows computer to check the code and the device, and mine worked fine with a Windows version compiler. Have you tried programming it on a Windows computer? XP works best for me.

EDIT: That shield is not the one I use. Maybe the others can help with that model.


Please post you network info an code...

Also a lot of routers like the ones you mention will NOT show devices with static IP in the attached device list. 


Is my ethernet shield just dead or something?

The ENC28J60 Ethernet Shield is not for beginners. You may want to read and post in the network forum section where there is some discussion about this type of shield.
Google forum search: Use Google Search box in upper right side of this page.
Why I like my 2005 Rio Yellow Honda S2000  https://www.youtube.com/watch?v=pWjMvrkUqX0



i received my arduino mega2560 board and the ethernet shield today.

it seems, I've got the same problem.

the router does'n show the board but i can ping it! --> try it your self.

i tried to install the web-server-example too but my browsers doesn't shown anything. on the other hand, they spend a lot of time to get some data from the arduino. in other cases, such as wrong ip addresses of the board is powered down, i get a error massage immediately.

nmap says, that there are no open ports (but port 80 should be open for incoming requests).

the ethernetshield i've got, must be a new one. the pcb-layout is a different than all i've ever see'n before. so the led's for tx and rx are left and right from the rj45 jack and the resetbutton is lcated near by the sd-slot. may be there are some difference?

I'm using gentoo linux and install the arduino-software from an overlay via layman, hosted by arduino.cc. the package is named  "dev-embedded/arduino-0021".

if anyone has an idea or may be a solution, please let us/me know.

thank's a lot!


If the board is alive and has a connection to a switch you can check the arp table of the switch.
on cisco : show ip arp
The board must use it's MAC address in order to communicate with a switch at level 2 of the OSI model.

Ergo : if it is alive and responding on any level or protocol, it shows it's MAC address in the arp table.
On the board and switch the link indicators must be litt (OSI level 1).


hi noorman!

thanks, thats it.

i replaced the default mac from the example with this one from the shield and now the tcp-port-80 is shown as open.

ok, opera, firefox or konqueror doesn't show anything. but i was able to download a file named "TDtrRUJF.bin.part". (atached)

it contains the values an a lot of other cryptically stuff but who knows may be thats importen...

thank you for response! good night...


More info would still be good.

How are you trying to connect to the shield WAN or LAN ?
IP address ?
Subnet mask ?
default gateway ?
DHCP range (if used) ?
MAC Address ?
Firewall Rules ?
Hardware ?
Can you ping it ?


Figured it out from some simpler thinking!

Turns out the ENC28J60 Ethernet Shield uses a different library to the standard built-in library seen in the examples sketchbook. I found the library for the ENC28J60 Ethernet Shield here:  http://blog.thiseldo.co.uk/?p=504

Didn't need to mess around with IP addresses too much, just changed it to a free IP in the range specified by the router.

Extremely simply to use - this is why I love the Arduino! Thanks for the help, hopefuly this thread will bounce infront of others experience the same problems.

Go Up