Go Down

Topic: Arduino and Mosfet module (Read 355 times) previous topic - next topic

davax

Sep 14, 2020, 08:27 pm Last Edit: Sep 14, 2020, 08:29 pm by davax
Why is arduino running ? I did not send the signal to turn mosfet on

https://imgur.com/fcqf3uo

UKHeliBob

Please do not send me PMs asking for help.  Post in the forum then everyone will benefit from seeing the questions and answers.

davax

#2
Sep 15, 2020, 08:32 am Last Edit: Sep 15, 2020, 08:38 am by davax
?



UKHeliBob

Please do not send me PMs asking for help.  Post in the forum then everyone will benefit from seeing the questions and answers.

davax

? why is arduino on , and mosfet is off

UKHeliBob

Your circuit looks wrong

Shouldn't the battery go to VIN on the MOSFET module  and the V- and V+ terminals supply power when the signal pin is taken HIGH ?

It would help if you described what you are trying to do
Please do not send me PMs asking for help.  Post in the forum then everyone will benefit from seeing the questions and answers.

davax

#6
Sep 15, 2020, 04:01 pm Last Edit: Sep 15, 2020, 04:02 pm by davax
So everything is turned off

I will add a button , which when i hold it will direct power the arduino from battery , until it turns the Mosfet ON

And after 2 minits i added in code , arduino turns the Mosfet OFF ,  and everything is off , so no power consuption ...

UKHeliBob

Quote
I will add a button , which when i hold it will direct power the arduino from battery , until it turns the Mosfet ON
Please post a diagram of your complete circuit

Noting what I said in reply #5, are you sure that VIN and GND of the MOSFET module should be connected to VIN and GND on the Arduino ?
Please do not send me PMs asking for help.  Post in the forum then everyone will benefit from seeing the questions and answers.

davax

#8
Sep 15, 2020, 05:44 pm Last Edit: Sep 15, 2020, 05:48 pm by davax
I connected it now like you said and same


When i connect the battery wires arduino is ON , but it need to be off right ? because there is no signal to turn it on

My only problem is why is arduino always ON ?
Mosfet is like relay right ?  When i give signal (power) to coil then it turns on

But here it is always on !





davax

Look , arduino works , and there is no input , to turn mosfet on


UKHeliBob

Take the Arduino out of the circuit until you know what you are doing.  The picture in reply #9 shows the battery connected between V+ and V-.  Why ?
Please do not send me PMs asking for help.  Post in the forum then everyone will benefit from seeing the questions and answers.

davax

Only difference is , there is arduino  and no motor ,...





UKHeliBob

In the picture in reply #9 your battery is connected to V+ and V-

In the diagram in post #11 the power is connected to VIN and GND

Spot the difference
Please do not send me PMs asking for help.  Post in the forum then everyone will benefit from seeing the questions and answers.

davax

I tried both cases , and same happens

Nvm , i will use relay,  with relay works normal..

thanks anyway :)

Go Up