Go Down

Topic: Failure to Upload after a Successful Bootload (Read 370 times) previous topic - next topic

durotimi

Hi there,

I have started from scratch and built an Arduino on a breadboard as per - https://www.arduino.cc/en/Main/Standalone

I have successfully boot-loaded an ATMEGA328P - PU chip. I did this using the offline IDE v1.8.13. For some reason my Mac, which runs OS Catalina 10.15.6, does not recognise either the Breakout board USB nor the USBtinyISP USB connections. Despite this, by choosing not to select a Port, I am still able to successfully boatload (screenshot attached - so by not choosing either the bluetooth option or cu.URT0 I am still able to upload).

The issue then happens when I try to upload a sketch e.g blink_led. When I try offline, I get the message ''Serial Port Not Selected'' with only the previously mention ports to choose from. Both do not work. (Attachment 2)

I then tried uploading using the online IDE with the Arduino Create plugin, it fails to recognise the board and I get an ''Error Uploading, check if the selected board is currently unavailable''. (Attachment 3)

Please could you advise me on what I need to do?

Best,

Timi






westfw

Quote
does not recognise either the Breakout board USB
And what brand/style is that?  Have you installed drivers for it?

durotimi

Brand/Style: SparkFun USB to Serial Breakout FT232RL

... and yes, the driver I installed was from the FTDI website, VCP v2.4.4 (64-bit).

durotimi

#3
Sep 17, 2020, 01:32 pm Last Edit: Sep 17, 2020, 01:38 pm by durotimi
It works... simple solution - change wires.


I am now getting this error when uploading...

User configuration file is "/Users/rotimi/.avrduderc"

User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/cu.usbserial-AQ00XXB3

Using Programmer : arduino

Overriding Baud Rate : 57600

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done. Thank you.



Looking at other posts, some suggest I need to change the SHELL for avrdude on my computer. I am not a specialist and so please could you confirm this will not damage my laptop?

Website: http://www.ladyada.net/learn/avr/setup-mac.html

durotimi

SOLVED! 

Just for those that may experience similar issues, just before I upload, I hold down the reset push button and release it a few seconds after the upload button is pressed.

Go Up