Go Down

Topic: Lenrpaket Arduino - welchen Arduino als Ersatz nehmen ? (Read 4835 times) previous topic - next topic

Kraeuterbutter

hab mir dieses "Lernpaket Arduino" von FRANZIS gekauft

bin ehrlich gesagt etwas enttäuscht:
79 Euro für ein paar LEDs, einen ARduino und ein Buch ?

wenn das Buch wenigstens klasse, wäre..
aber allein die ersten 30 Seiten sind eher Werbung, und auf der Arduino.cc Seite zu finden

gut..
mein Problem: ich krieg den Arduino nicht zum Laufen
dachte zuerst es läge an meiner Virtuellen Maschine..
aber auch am Host (win7 64bit) gings nicht
an anderem Desktop-Rechner mit WinXP das Selbe

immer Synchronisationsproblem beim Versuch ein Programm hochzuladen

ich habe allerdings auch einen Arduino Nano bei ebay ersteigert, mit dem funktionierts !
deshalb denke ich, dass es ja wohl nicht an der Software oder meinen REchnern liegen kann (?)

gut: kann ich alles, was ich mit dem grossen bauen kann, auch mit dem kleinen Nano realisieren ?

muss mir halt an jedes Kabel eine kleine Buchse dranlöten, da ja der Nano Pins hat, und der grosse ARduino Buchsenleisten

falls ich mir für den grossen doch einen Ersatz besorgen sollte:
welcher wäre den kompatibel zum Lernpaket, welcher wäre denn empfehlenswert ?




uwefed

Jeder Arduino wird an einem anderen COM-Port erkannt. Hast Du den richtig eingestellt?
Schreib mal wo Du wohnst, vieleicht kann Dir jemand in der Nähe helfen.
Falls der Arduino wirklich kaputt ist, ist er noch in Garantie und frage den Händler um das Lernpaket umzutauschen.
Als Ersatz kannst Du einen Arduino 2009 (ist das Auslaufmodell und etwas billiger) oder der Arduino UNO (ist das aktuelle Version) nehmen. Beide sind kompatiebel der Unterschied ist hauptsächlich das IC für die USB-Schnittstelle. Die restlichen Unterschiede sind für einen Anfänger nicht rilevant.

Händler findest Du unter:
http://arduino.cc/en/Main/Buy

Viele Grüße Uwe


Kraeuterbutter

Hi...
Com-Port glaub ich schon, dass ich den richtigen verwende:

zeitweilig wurden mir 2 angezeigt, wovon einer beim An und abstecken des ARduinos auftaucht bzw. verschwindet
im Moment wird immer nur einer angezeigt, welcher beim an-und-abstecken des ARduino eben da ist oder nicht

denke also, dass dies der richtige Comport sein müsste
bin aus Wien


der Nano hat eine andere Nummer...
Nano funktioniert, aber eben leider Stiftleiste und ich gerade gesehen, dass ich keien passenden Buchsen hier habe
--> kann also nicht weiterspielen  (mag jetzt ned für keline LED-Experimente am Nano rumlöten)


danke für deine Antwort


marcusw

hi.

Den nano kann man super mit einem Breadboard verwenden:


Dadurch sparst du dir rumgelöte. Lies dich am besten mal ein, wie ein Breadboard funktioniert.

uwefed

Wenn kein neuer COM-port auftaucht, wenn Du den Arduino ansteckst, heißt das, daß der Arduino keine Verbindung mit den Computer aufbaut. Hast Du mal einen anderen USB-Kabel genommen?
Welcher Arduino ist im Lernpacket? Müßte ein Freeduino sein. Der benutzt den gleichen Treiber wie der Arduino Nano.

Viele Grüße nach Wien
Uwe

madworm

#5
Aug 28, 2011, 12:08 pm Last Edit: Aug 28, 2011, 12:09 pm by madworm Reason: 1
Schon einen loop-back test gemacht ?

Wenn das tut, dann koennte der bootloader auf dem board auf eine falsche baud-rate eingestellt sein. Dazu koennte man in der boards.txt die werte aendern. Typisch sind 19200, 57600 und 115200 (optiboot).

Im uebrigen sind fuer bastel fanatiker varianten interessanter, bei denen der USB adapter und das eigentliche board getrennt voneinander ausgefuehrt sind. Da braucht man dann nicht gleich alles in die tonne zu treten. Ist i.d.r. auch billiger, wenn man preise vergleicht. Z.b. bei watterott hat es einige kleine boards fuer wenige euros. Der nano ist schon etwas hochpreisig.

Kraeuterbutter

Hallo...
also com-port taucht beim an und abstecken auf...
daran sollte es nicht liegen


die idee mit dem Bread-Board für den Nano --> danke !
werd noch eines bestellen

der nano soll später in einem Projekt zum Einsatz kommen, und wurde gewählt, da er klein genug ist um in einer Fahrrad-Sattelstange unsichtbar zu verschwinden...   (+  zwei 18650 LiMn-Zellen + 5V Spannungswanlder)

Preis: habe 15Euro für den nano gezahlt  (Porto war frei)
find ich ok...


Loopback-Test: hab mal gegoogelt und diese Anleitung gefunden:
Quote
1. Disconnect power from the board

2. Remove all connections and shields from the board

3. Force the processor to remain in reset by connecting a jumper from RESET to GND

4. Connect a jumper from the TX pin (1 on the Uno) to the RX pin (0 on the Uno)

5. Connect the board to your computer.  After a brief pause Windows will produce a device-insertion tone if sound is enabled.  Linux may or may not produce a device-insertion tone; an entry is added to the system log.

6. Start your favourite terminal application.  Serial Monitor will work fine.

7. Connect the terminal application to the serial port for your board.  The baud rate is irrelevant.

8. Send data by typing.  Everything you type should be echoed back.  To send data, some terminal applications, like Serial Monitor, require pressing the Enter key or clicking a Send button.  If exactly what you send is echoed back then the board passes the test.  This means that the host computer hardware driver, USB cable, and USB to serial converter are all working.

9. Shutdown the terminal application

10. Disconnect the board from the computer

11. Remove the two jumpers


was ich beim Serial Monitor der Arduino-Entwicklungsumgebung eingebe, wird dann im Editfenster darunter ausgegeben..

demnach passt hardware driver, USB Kabel und Serial Converter


hmm...










Kraeuterbutter




Wenn das tut, dann koennte der bootloader auf dem board auf eine falsche baud-rate eingestellt sein. Dazu koennte man in der boards.txt die werte aendern. Typisch sind 19200, 57600 und 115200 (optiboot).



wäre das in dieser Datei dann:
[qutoe]##############################################################

diecimila.name=Arduino Diecimila, Duemilanove, or Nano w/ ATmega168

diecimila.upload.protocol=stk500
diecimila.upload.maximum_size=14336
diecimila.upload.speed=19200

diecimila.bootloader.low_fuses=0xff
diecimila.bootloader.high_fuses=0xdd
diecimila.bootloader.extended_fuses=0x00
diecimila.bootloader.path=atmega
diecimila.bootloader.file=ATmegaBOOT_168_diecimila.hex
diecimila.bootloader.unlock_bits=0x3F
diecimila.bootloader.lock_bits=0x0F

diecimila.build.mcu=atmega168
diecimila.build.f_cpu=16000000L
diecimila.build.core=arduino

##############################################################[/quote]

der Fette wert ?
was sollte da stehen ?
oder was anderes ?

Kraeuterbutter


uwefed

#9
Aug 28, 2011, 12:34 pm Last Edit: Aug 28, 2011, 12:50 pm by uwefed Reason: 1

Preis: habe 15Euro für den nano gezahlt  (Porto war frei)
find ich ok...

15 € ist zu wenig für einen NANO der kostet um die 33€. Wird der Nano auch schon gefälscht? Oder hast Du einen MINI oder MINI PRO? (sind ohne aufgelötetes USB-interface)

Quote from: Kraeuterbutter

was ich beim Serial Monitor der Arduino-Entwicklungsumgebung eingebe, wird dann im Editfenster darunter ausgegeben..
demnach passt hardware driver, USB Kabel und Serial Converter
hmm...

Ja, das alles funktioniert also.

Grüße Uwe

Kraeuterbutter

http://www.ebay.de/itm/270707876013?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649


und er funktioniert

kurti

Hallo Kräuterbutter,

- hast Du den Jumper für die Spannungsversorgung richtig eingestellt ?
- Hast Du den richtigen Chip ausgewählt ? ATmega168

zumindest war in meinem Lernpaket ein Arduino Diecimila enthalten.

Gruss
Kurti
Zitat Jurs: falsche Verkabelung ist sowieso immer wenig förderlich für das Funktionieren der Hardware



hier könnte Ihre Werbung stehen


df6ih

Bei meinem lag der Microprozessor lose dabei ... *nur mal so* ;)

uwefed


http://www.ebay.de/itm/270707876013?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649
und er funktioniert

Scheint der Orginale zu sein. Ich erkläre mir aber nicht wieso er so billig ist ...
Grüße Uwe

Go Up