Go Down

Topic: Windows 7 (64 Bit) and Arduino 0022 (SOLVED) (Read 3985 times) previous topic - next topic

lamboalpha

Aug 29, 2011, 03:56 am Last Edit: Aug 30, 2011, 02:23 am by LamboAlpha Reason: 1
I just got an Arduino and are having problems running the Arduino 0022 IDE software. I have read several existing forum post (listed below) and none of them have helped (,actually they made the problem worse). Thank for any help.

Setup:
I open the blink example and try to upload it to the Ardunio.

First symptom:
Error message: avrdude: ser_send(): write error: sorry no info avail
Note: I did install the drivers and do have the correct serial port selected.

Second symptom: I try clicking upload a second time.
Error messages goes away, but it hangs at "Uploading to I/O Board..." I did notice that "avrdude.exe" is listed under Processes tag in Task Manager, but nothing ever happens (10+ minutes).

Tried:
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1251257342
http://www.ftdichip.com/Drivers/VCP.htm Beta and Certified, they results in an error that the serial port is already open.
http://arduino.cc/forum/index.php/topic,4069.msg31078.html#msg31078
I have tried running it as an Administrator.
I have try redownloading Arduino 0022.

Update: Extra information:

The board is an Arduino Uno (ATmega328). The board and cable are working fine (I have tested it on a Windows XP machine) and uploading the code.

When I try to upload, the board does reset (the blink pattern on the pin 13 LED does change, as I have the blink sketch running, but at a faster than normal rate blink rate). It then return to the faster blink pattern (and does not change to the normal/slower blink rate). It reset the setup, I have to unplug the the USB from the Arduino to clear the second error message (which kills the avrdude task and then when I click upload, I get the first error message again).

spycatcher2k

Hi - I have W7/64 : here is my setup routine

Download IDE & Install into a directory not system protected - I have a folder called mytools on c: , install into arduino-0022 folder in there
Plug in the Uno
Browse to the DRIVERS folder (NOT into any of the FTDI folders) when installing the drivers (The uno does not have the ftdi)
or Browse there and update the driver of the COM port
REBOOT <-- not required, but safer, allows plug and pray to settle down
look in device manager for UNO in ports, note the COM number
Open IDE, loads blink, select tools,board,uno - select tools,Serial Port, select one already seen above.
Upload.

Hope this helps

Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

lamboalpha

#2
Aug 29, 2011, 07:02 pm Last Edit: Aug 29, 2011, 07:05 pm by LamboAlpha Reason: 1
Thanks spycatcher2k,

While troubleshooting, I did learn/realize that the Uno do not use the FTDI drivers (which is why it made things worse when I did try using them). I have the Arduino Uno showing up properly in Device Manager. I did select the proper serial port in IDE (as my machine only has one). I did the same thing on Windows XP machine and it works fine, so I don't think I am doing something wrong. I will upload an example of the full debugging log tonight.

I keep thinking it has something to do with the avrdude.exe process. The board does reset when I try uploading, but it does not upload the sketch (no activity on the TX or RX LED).  I even tried downloading the latest version of WinAVR and replacing it in the Arduino folder.

I have also read the following posts:
http://arduino.cc/forum/index.php/topic,25517.0.html
http://arduino.cc/forum/index.php/topic,70701.0.html
http://arduino.cc/forum/index.php/topic,26685.0.html
http://arduino.cc/forum/index.php/topic,47924.0.html
http://arduino.cc/forum/index.php/topic,61404.0.html I am going to try this when I get home tonight, why not, as I do have the Arduino plugged into a power hub.

lamboalpha

The last topic which I listed above had the solution. I unplug the Ardunio from the powered hub and plugged it directly into my machine. It worked!  I tried this several times, it does not work when it is plug into the powered hub. I did tried it with a power supply plugged into the Ardunio, but it still does not work if it is plugged into the hub. I tried it through the USB hub on my KVM switch and it works fine.

Go Up