Go Down

Topic: Help on 2.3 - Digital Inputs from Tutorial Book (Read 211 times) previous topic - next topic

droidus

When I press the left button, the LED will not turn on.  I've tried replacing the LED, but yet, nothing happens. 


larryd

#1
Oct 09, 2020, 10:18 pm Last Edit: Oct 09, 2020, 10:21 pm by larryd
Have no idea what 2.3 is.


Do you have the flat side of the LED going to GND ?

Looks like you might have the right switch interfering with the LED cct.

Let's see the schematic.

Use diagonal corners with those switches.



Use CTRL T to format your code.
Attach your sketch between code tags
[code]Paste your sketch here[/code]





No technical PMs.
If you are asked a question, please respond with an answer.
If you are asked for more information, please supply it.
If you need clarification, ask for help.

droidus

#2
Oct 09, 2020, 10:45 pm Last Edit: Oct 09, 2020, 10:47 pm by droidus
Have no idea what 2.3 is.


Do you have the flat side of the LED going to GND ?
Yes, I do.

Looks like you might have the right switch interfering with the LED cct.

Let's see the schematic.


Use diagonal corners with those switches.
Which diagonal corners do  I want to use?  Their diagram shows it the way I have it configured.



larryd

#3
Oct 09, 2020, 10:50 pm Last Edit: Oct 09, 2020, 10:54 pm by larryd
" Which diagonal corners do  I want to use?  Their diagram shows it the way I have it configured. "

It doesn't matter, just use opposite corners.

Is the 'right switch' interfering in the LED wiring ?




Attach your sketch so we can see the complete code.

Use CTRL T to format your code.
Attach your sketch between code tags
[code]Paste your sketch here[/code]





No technical PMs.
If you are asked a question, please respond with an answer.
If you are asked for more information, please supply it.
If you need clarification, ask for help.

TomGeorge

Hi,
Is the yellow jumper connected to gnd on the controller, hard to see in the picture.

Can you please post your code?

Thanks.. Tom.... :)
Everything runs on smoke, let the smoke out, it stops running....

johnerrington

Can you post a link to the tutorial you are using?

If you take the link out of D5 and connect it to +5V does the LED light?

If you put it back and write a "1" to D5 does the LED light?
I'm trying to help. If I find your question interesting I'll give you karma. If you find my input useful please give me karma (I need it)

Paul__B

You appear to have the 220 Ohm resistor and white wire connected to the ground terminal of the right hand button.  :smiley-eek:

droidus

You appear to have the 220 Ohm resistor and white wire connected to the ground terminal of the right hand button.  :smiley-eek:
Doh!  Thank you.  That fixed it! 

larryd

This was a hint that went way over your head from post #1


"Looks like you might have the right switch interfering with the LED cct."


You must read . . . . .



No technical PMs.
If you are asked a question, please respond with an answer.
If you are asked for more information, please supply it.
If you need clarification, ask for help.

Paul__B


larryd

#10
Oct 11, 2020, 12:27 am Last Edit: Oct 11, 2020, 12:27 am by larryd
Stronger hint than:  " the right switch interfering with the LED cct"

Hmm, OP better take up fishing.



No technical PMs.
If you are asked a question, please respond with an answer.
If you are asked for more information, please supply it.
If you need clarification, ask for help.

Go Up